Jak mogę dezaktywować klawisze F1 i F10 w gnome-terminalu?

115

Jak mogę wyłączyć powiązania klawiszy F1 (pomoc) i F10 (menu powiadomień)?

Najpierw potrzebuję narzędzia ekranowego, a na drugim wyjściu mc w konsoli.

W ustawieniach systemowych Skróty klawiaturowe nie ma takich powiązań klawiszy.

    
zadawane Marko Kevac 27.04.2011, 15:55
źródło

14 odpowiedzi

107

11.04

Wyłączanie skrótu F1

  1. W gnome-terminalu otwórz Edytuj ➜ Skróty klawiszowe .

  2. Przewiń w dół do skrótu Pomoc / Spis treści , kliknij tam, gdzie jest napisane "F1" i naciśnij Backspace :

WyłączanieskrótuF10

  1. Zainstaluj compizconfig-settings-manager pakiet.

    • Ostrzeżenie: Jakie są niektóre problemy z CCSM i dlaczego chciałbym go ominąć?
  2. Otwórz Menedżer ustawień CompizConfig .

    • Hit Super , aby otworzyć Dash, wpisz "Compiz" i naciśnij Enter .
  3. Wpisz "jedność" w elemencie Filtruj i wybierz Ubuntu Unity Plugin .

  4. Kliknij przycisk po prawej stronie klawisza , aby otworzyć pierwsze menu panelu i odznaczyć pole wyboru Włączone .

  5. TowyłączaskrótglobalnyF10,terazwyłączskrótklawiszaskrótuF10gnome-terminal:

    • Wgnome-terminaluotwórzSkrótyklawiaturowe(Edytuj➜Skrótyklawiaturowe)i
      odznaczWłączklawiszskrótumenu(domyślnieF10)

  6. F10 jest mapowany na menubar_accel przez coś w Ubuntu. Gnom? Metacity? Nie wiesz, co to jest, co to kradnie, ale klucz nie trafia do Eclipse.

    • Uruchom gconf-editor, przejdź do / desktop / gnome / interface, a następnie przewiń w dół do menubar_accel i usuń wartość F10. [Skradziono stąd]
odpowiedział Isaiah 23.06.2011, 20:52
źródło
44

Wyłącz F10 na gnome-terminalu w 12.04

Wpisz to w konsoli:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Następnie zamknij wszystkie sesje terminalowe. Teraz powinno działać tak, jak powinno (na przykład w mc ).

odpowiedział Paweł Gościcki 30.04.2012, 21:25
źródło
23

uruchom gconf-editor i wykonaj /apps/gnome-terminal/keybindings/help

Opis:

"Klawisz skrótu klawiaturowego do uruchamiania pomocy Wyrażony jako ciąg znaków w tym samym formacie, co pliki zasobów GTK + Jeśli ustawisz opcję na specjalny ciąg" wyłączony ", wówczas nie będzie skrótu klawiaturowego dla tej akcji."

    
odpowiedział Rinzwind 21.08.2011, 22:28
źródło
7

Jestem nowy w Linuksie i ten klucz F10 doprowadza mnie do szału. Wszystkie powyższe triki nie działały, ale znalazłem rozwiązanie (dla Ubuntu 11.10 z klasycznym desktopem Gnome 3). W terminalu wprowadź następującą komendę:

gsettings set org.gnome.desktop.interface menubar-accel ""

Z edytorem dconf można stwierdzić, że F10 naprawdę zniknął. Zauważ, że tego rodzaju sztuczki wydają się być zależne od wersji Gnome / Ubuntu.

    
odpowiedział gast128 29.11.2011, 20:34
źródło
4

Aby wyjść z mc (klawiszem F10). Wyłącz "Key, aby otworzyć pierwsze menu panelu" w plugin compiz (ccsm)

    
odpowiedział kholis 29.04.2011, 12:33
źródło
4

@kholis jest właściwy dla wyłączenia F10 w Unity, ale jeśli jesteś nowicjuszem jak ja, potrzebujesz trochę więcej informacji, aby to zadziałało.

Jeśli nie jest jeszcze zainstalowany, zainstaluj compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Uruchom nowo zainstalowany menedżer ustawień i filtruj "jedność"

Edytuj "Klawisz, aby otworzyć pierwsze menu panelu", aby go wyłączyć lub zmienić na inny klawisz.

Nie znalazłem jeszcze sposobu na zmianę F1.

odpowiedział Ryan Sorensen 30.04.2011, 19:36
źródło
3

Instrukcja link (cytowana poniżej) działa również w systemie Ubuntu 11.04. (Wydaje się, że wyłącza F1 zarówno na pulpicie, jak i na terminalu, to znaczy, że F1 nie wysyła sekwencji ansi do powłoki w terminalu, jeśli tego właśnie potrzebował OP.)

  
  1. Przejdź do System - Preferencje - Skróty klawiaturowe
  2.   
  3. Utwórz nowy skrót. Nazwij go "nic nie rób" i wpisz "false"   (bez cudzysłowów) w polu "polecenie". Naciśnij ok.
  4.   
  5. Przewiń do dolnej części listy i znajdź nowe polecenie. Kliknij   na "Wyłączone" po prawej stronie i naciśnij F1.
  6.   
    
odpowiedział David Andersson 22.08.2011, 04:12
źródło
3

Możesz go łatwo wyłączyć za pomocą CCSM (Kliknij, aby zainstalować, jeśli go nie masz ).

Następnie przejdź do pulpitu - > Plugin Ubuntu Unity - > Klawisz, aby otworzyć menu pierwszego panelu i wyłączyć go lub zmienić na inny skrót klawiaturowy.

Uwaga : wygląda na to, że ta metoda nie działa w Unity2D.

    
odpowiedział Binarylife 27.10.2011, 00:03
źródło
2

To jest wskazówka dla użytkowników Thnkpad, szczególnie T60. Zmień ponownie klawisz F1, aby uciec. Eliminuje to irytujące wyskakujące okienko pomocy terminalowej po uderzeniu w F1. Często robisz to ze względu na zabawne umieszczanie ESC na T60.

    
odpowiedział ncmathsadist 03.12.2011, 18:42
źródło
1

Jeśli chcesz to zmienić w Gnome Terminal , możesz kliknąć Edytuj> Skróty klawiaturowe w Terminalu.

    
odpowiedział Jeremy Bicha 30.04.2011, 20:37
źródło
1

Zalecam używanie F1 jako skrótu do czegoś innego. Używam Tilda, terminalu wiersza poleceń w stylu trzęsienia ziemi, a domyślnym skrótem jest F1. Zastępuje Pomoc, więc nigdy nie uruchomiłem Pomocy po naciśnięciu F1. Nawet jeśli nie spodoba ci się Tilda, ponowne uderzenie w F1, aby ją ukryć, jest o wiele mniej uciążliwe niż zamknięcie Pomocy po przypadkowym uruchomieniu.

    
odpowiedział titaniumtux 03.12.2011, 20:23
źródło
1

12.04

F1 nie wydaje się robić niczego po wyjęciu z pudełka 12.04
F10 pojawia się, aby zasymulować kliknięcie prawym przyciskiem myszy
W odpowiedzi na specyfikę pytania nie trzeba wyłączać pomocy i powiadomień.

Nadal możesz zmapować je na coś podobnego:
Odwzorowywanie skrótów klawiszowych w 12.04 odbywa się po prostu za pomocą widgetu Klawiatura.

W launcherze Unity znajdź klawiaturę.

Wotwartymokniewybierzkartęskrótówiniestandardoweskróty.
Kliknijznakplus,abydodaćnowyskrót.

Nazwij go czymkolwiek, co pasuje do funkcji, którą przypisujesz.
Wpisz polecenie, które ma być uruchamiane w poleceniu.

Poprawejstronieoknakliknijmiejsce,wktórymjestwyłączone.Powinnotozostaćprzełączonenanowyakcelerator.

Teraz wystarczy kliknąć F10 .
Akcelerator niestandardowych skrótów zastępuje zachowanie symulacji kliknięciem prawym przyciskiem myszy. Możesz ustawić to polecenie na echo 'nope' > /dev/null , jeśli chcesz, aby twój F10 nic nie robił.

    
odpowiedział RobotHumans 02.04.2012, 19:50
źródło
1

12.04 Bez jedności - wyłącz zachowanie F1 i F11

Zainstalowałem Ubuntu 12.04 / 64 i całkowicie usunąłem Unity z niego, postępując zgodnie z tymi wskazówkami. . Wiele narzędzi, które modyfikują zachowanie Jedności, nie działa. W szczególności CCSM nie "widzi" skrótów klawiaturowych.

Zauważyłem, że metoda wykorzystująca Edycja-> Skróty klawiaturowe w oknie terminala również nie działa. Po odrobinie zabawy stwierdziłem, że patrząc dalej Skróty klawiaturowe w sekcji Skróty klawiszowe , F1 i F11 nadal były zdefiniowane dla ich skrótów.

Aby to naprawić,

  1. Kliknij "F11" w polu po prawej stronie linii, która definiuje F11 jako pełny ekran. Tekst zmieni się na "Nowy akcelerator ...".

  2. Wpisz inną, mniej kontrowersyjną sekwencję klawiszy (np. alt-F11) i to kombinacja klawiszy zastąpi skrót. Jeśli ktoś wie, jak wpisać "nic", daj nam znać.

  3. Powtórz dla klawisza F1.

odpowiedział Wes Miller 20.11.2013, 17:33
źródło
0

Ctrl + F1 też nie działa. Rozwiązanie jest takie samo jak w przypadku Shift + F10. Nie zapomnij o średniku jako separatorze!

Umieść to w ~ / .config / gtk-3.0 / gtk.css:

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10";
     unbind "<control>F1";
}

* {
     gtk-key-bindings: NoKeyboardNavigation;
}
    
odpowiedział egmont 16.03.2014, 12:46
źródło

Przeczytaj inne pytania na temat tagów