Nie można zainstalować Skype 4.3 na 64-bitowym systemie Ubuntu 14.04

19

Po pierwsze, myślę, że to pytanie nie jest duplikowane, ponieważ próbowałem wszystkich innych rozwiązań, które tu znalazłem, ale nic nie rozwiązało mojego problemu.

Używam 64-bitowego Ubuntu 14.04.

Próbowałem do tej pory: sudo apt-get install skype - > To nie zadziałało. Błąd:

The following packages have unmet dependencies:
skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

Próbowałem sudo dpkg add-architecture & amp; & amp; sudo dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb ale też nie działało. Błąd:

dpkg: dependency problems prevent configuration of skype:
skype depends on libqt4-dbus (>= 4:4.5.3); however:
Package libqt4-dbus is not installed.
skype depends on libqt4-network (>= 4:4.8.0); however:
Package libqt4-network:i386 is not installed.
skype depends on libqt4-xml (>= 4:4.5.3); however:
Package libqt4-xml:i386 is not installed.
skype depends on libqtcore4 (>= 4:4.7.0~beta1); however:
Package libqtcore4:i386 is not installed.
skype depends on libqtgui4 (>= 4:4.8.0); however:
Package libqtgui4:i386 is not installed.
skype depends on libqtwebkit4 (>= 2.2~2011week36); however:
skype depends on libstdc++6 (>= 4.2.1); however:
Package libstdc++6:i386 is not installed.
skype depends on libx11-6; however:
Package libx11-6:i386 is not installed.
skype depends on libxext6; however:
Package libxext6:i386 is not installed.
skype depends on libxss1; however:
Package libxss1:i386 is not installed.
skype depends on libxv1; however:
Package libxv1:i386 is not installed.
skype depends on
dpkg: error processing package skype (--install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Errors were encountered while processing:
skype

Próbowałem użyć po sudo apt-get -f install , ale to nie rozwiązało.

Próbowałem zainstalować przy użyciu Gdebi . Błąd:

Cannot install 'libqtwebkit4:i386'

Próbowałem zainstalować przy użyciu Ubuntu Software Center . Błąd:

Cannot install 'libqtwebkit4:i386'

Próbowałem zmienić serwer w "Oprogramowaniu i aktualizacjach". Próbowałem użyć "Serwera głównego" i "Serwerów dla Stanów Zjednoczonych". Ale nie mógł rozwiązać mojego problemu.

Ktoś ma pojęcie, jak to rozwiązać?

SOLVED

Cóż, sformatowałem komputer i zainstalowałem najpierw Skype'a. Przypuszczam, że prawdopodobnie była to kolejna instalacja, którą wykonałem przed instalacją Skype'a.

Dzięki ludziom!

    
zadawane z_inx 30.07.2014, 20:29
źródło

9 odpowiedzi

32

Mam 14.04 64bit, oto jak zainstalowałem.

Pobrano skype 4.3 z tutaj , a także użył Gdebi, aby go zainstalować i zainstalował się dobrze. jeśli nie masz zainstalowanego Gdebi, po prostu naciśnij klawisze Ctrl + Alt + T na klawiaturze, aby otworzyć Terminal. Kiedy się otworzy, uruchom poniższe komendy:

sudo apt-get install gdebi

Jakjużpowiedziałem,niemiałemżadnychwydańzapomocąmetodyopisanejpowyżej.Kolejnarzecz,którąmożeszzrobić,abynaprawićuszkodzonepakiety,możeszzrobić

sudoapt-getclean&&sudoapt-getupdatesudoapt-getupgrade

LUB

Przejdźdomenedżerapakietówsynaptic,jeśligozainstalowałeś,przejdźdoEdycja->Naprawuszkodzonepakiety.

Alternatywnymsposobeminstalacjijest

sudodpkg--add-architecturei386sudoapt-getupdatewget-Oskype-install.debhttp://www.skype.com/go/getskype-linux-debsudodpkg-iskype-install.deb

Potym,jeślipojawisięjakikolwiekbłąd,np.niemożnazainstalować"libqtwebkit4: i386" lub jakiejś innej paczki, spróbuj tego polecenia.

     sudo apt-get upgrade --fix-missing

Sugeruje wypróbowanie następującego polecenia.

    sudo apt-get -f install

Po wykonaniu powyższego polecenia, spróbuj jeszcze raz.

sudo dpkg -i skype-install.deb

Aby uzyskać więcej informacji, odwiedź oficjalne forum Skype tutaj .

Mam nadzieję, że to ci pomoże :)

    
odpowiedział Mitch 30.07.2014, 20:44
źródło
4

Pierwsze uruchomienie:

sudo apt-get install -f

aby zainstalować deps związany z OS 14.04LST 64 bit, a następnie spróbuj poniżej poleceń ... skype 4.3 instaluje się idealnie

sudo dpkg --add-architecture i386
sudo apt-get update
wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

To działało dla mnie .... ;;;; :)

    
odpowiedział suri 05.08.2014, 16:13
źródło
2

Uruchamianie następujących poleceń:

sudo apt-get clean && sudo apt-get update
sudo apt-get upgrade

Rozwiązał problem dla mnie.

    
odpowiedział nick 05.08.2014, 14:26
źródło
2

Kroki:

sudo sh -c "echo 'deb http://archive.canonical.com/ubuntu/ trusty partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype
    
odpowiedział John Foley 21.10.2014, 22:54
źródło
1

Mam taki sam problem z instalacją Skype 4.3 na Ubuntu 13.10. Jednak, postępując zgodnie z powyższymi instrukcjami, Skype 4.2 zawsze pokazuje się ket, nawet po usunięciu skype przed pobraniem nowszej wersji. Aby to zadziałało, musiałem usunąć plik konfiguracyjny .Skype z mojego katalogu domowego:

rm -r ~/.Skype

Nie martw się, nie stracisz kontaktów ani niczego innego. Jedyna drobna irytacja, jaką mogę zobaczyć, że na początku niektóre z twoich kontaktów pojawią się ze swoją nazwą skype, a nie znaną pełną nazwą.

    
odpowiedział Marc Corluy 25.08.2014, 12:59
źródło
1

W moim przypadku mam ten sam problem z nieprzestrzegania zasady RTFM :) Zainstalowałem niektóre pakiety z xorg-edger, a następnie nie usunąłem ich poprawnie, jak to zostało powiedziane w komentarzu do instalacji (tj. Właśnie usunięto repozytorium, ale nie zainstalowane pakiety). Spowodowało to efekt domina, który powodował, że nie można zainstalować żadnych pakietów zależnych od biblioteki i386 ...

Znalazłem go, próbując zainstalować pakiety z aptitude, które bezpośrednio rozwiązują problemy (różne wersje 64-bitowych pakietów). Następnie dodałem repozytorium xorg-edgers i usunąłem je poprawnie za pomocą:

sudo apt-get install ppa-purge
sudo ppa-purge xorg-edgers

Mam nadzieję, że to pomoże komuś ...

    
odpowiedział Karel Lenc 25.08.2014, 19:42
źródło
1

Naprawiłem ten sam problem, włączając "Zalecane aktualizacje (sprawdzone aktualizacje)" w panelu sterowania "Oprogramowanie i aktualizacje", zakładkę "Aktualizacje".

    
odpowiedział Douglas Held 24.11.2014, 19:04
źródło
0

Zaktualizowałem do wersji 4.3.0.37 , ponieważ wersja 4.2.0.13 nie pozwalała mi już się logować z błędem "Nie mogę się połączyć" .

Niestety dla mnie po wielu próbach nie mogłem zmusić pulseaudio do pracy nad moim systemem, działa tylko ALSA, więc przeszedłem z powrotem do wersji 4.2.0.13

Aby rozwiązać problem z logowaniem, podszywałem numer wersji 4.2.0.13 do najnowszej wersji 4.3.0.37 i logowanie znowu działało, problem został rozwiązany.

Aby rozwiązać problem, po prostu przejdź z powrotem na wersję 4.2.0.13 i podróbkę 4.3.0.37 , zakończ Skype i uruchom to polecenie:

sudo sed -i "s/\x34\x2E\x32\x2E\x30\x2E\x31\x33/\x34\x2E\x33\x2E\x30\x2E\x33\x37/g" /usr/bin/skype

Po powrocie możesz normalnie się logować.

    
odpowiedział mikelinux 12.08.2014, 09:03
źródło
0

Dla tych, którzy próbowali wszystkich powyższych, ale wciąż walczą (tak jak ja):

Problem może być tylko serwerem używanym do aktualizacji Ubuntu (w moim przypadku). Serwer, z którego korzystałem, nie miał poprawnej definicji libqtwebkit4:i386 .

Aby to rozwiązać:

  • Otwórz ustawienia systemowe
  • Oprogramowanie i amp; Aktualizacje
  • Zakładka Ubuntu Software
  • Pobierz z (Inne ... i wybierz Najlepszy serwer)

Zaktualizuj system za pomocą sudo apt-get update , a następnie:

wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
sudo dpkg -i skype-install.deb

Opracowano dla mnie.

    
odpowiedział Raphael_b 15.05.2015, 18:17
źródło

Przeczytaj inne pytania na temat tagów