Ekran zmienia kolor na czarny po zmianie użytkowników

8

Stworzyłem trzech użytkowników na moim komputerze (administratorzy i zwykli użytkownicy), a ilekroć przełączam się między użytkownikami, mój ekran jest wyłączony.

Mam Ubuntu 16.10 i przełączam użytkowników za pomocą menu konta w prawym górnym rogu.

Objawy

Mam dwóch standardowych użytkowników, którzy mogą logować się bez hasła. Kiedy przełączam się między nimi:

  • Natychmiast i przez krótką sekundę Widzę ekran innego użytkownika.
  • Ekran się wyłącza (wskaźnik LED na ekranie zaczyna migać).
  • Teraz są dwie opcje:
    • Ekran włącza się ponownie po 1-3 sekundach.
    • Ekran pozostaje wyłączony, dopóki nie poruszę myszką lub nie kliknę klucza, tak jakby komputer był zawieszony.

Dodatkowe symptomy

Kiedy przełączam się na administratora, jest to bardziej skomplikowane:

  • Ekran miga przez sekundę.
  • Dostaję menedżera wyświetlania, w którym muszę wprowadzić moje hasło.
  • Użytkownik administracyjny może nie zostać wybrany - muszę go wybrać ponownie i wprowadzić hasło.
  • Jestem zalogowany i widzę ekran przez krótką sekundę .
  • Ekran miga.
  • Po raz drugi widzę menedżera wyświetlania. Tym razem nie ma listy użytkowników, tylko użytkownik administracyjny. Ponownie wprowadzam hasło i loguję się bez migania.
  • Widzę komunikat o błędzie:

Rzeczy, które nie działały:

  • Próbowałem klikając Ctrl + Alt + F7 , aby przełączać się między sesjami TTY. To czasami działa, ale przez większość czasu ekran wciąż się wyłącza.
  • Próbowałem dm-tool switch-to-user username . Jest to to samo, co kliknięcie menu.
  • Próbowałem zmienić opcje oszczędzania energii, aby wyłączyć tryb wstrzymania (ekran nigdy nie wyłącza się, gdy jest nieaktywny). Nie miało to żadnego wpływu.
  • Próbowałem przełączać menedżera wyświetlania na gdm3 . To było okropne. System nie uruchomił się i musiałem użyć głównej konsoli od Gruba, aby przywrócić lightdm.
  • dpkg-reconfigure lightdm .
  • Próbowałem używać kabla HDMI z moją kartą graficzną (Gigabyte RX 460 2G 1212Mhz WindForce2 OC) lub kabla VGA do mojej płyty głównej (ASUS H110M-K DDR4). Oba zachowują się tak samo.
  • Nie próbowałem instalować amdgpu-pro - to Wydaje się, że obsługuje tylko 16.04 i nie jest potrzebny w wersji 16.10 (z wbudowaną obsługą).

Podobne pytania bez odpowiedzi:

  • Black sreen po zmianie użytkownika
  • Pusty ekran po zmianie użytkownika lub wznowieniu
  • Ubuntu 16.04 LTS - Czarny ekran po zmianie użytkownika

Będę bardzo często przełączać użytkowników ... Jak mogę sprawić, żeby to działało sprawnie? Czy jest dziennik, który powinienem sprawdzić?

Znalazłem to na apport.log :

  

BŁĄD: apport (pid 19659) Fri 2 grudnia 12:22:40 2016: wezwany do pid 19445, sygnał 6, ograniczenie podstawowe 18446744073709551615
  BŁĄD: apport (pid 19659) Fri Dec 2 12:22:40 2016: ignorowanie nieprawdopodobnie dużego limitu rdzenia, traktowanego jako nieograniczony
  BŁĄD: apport (pid 19659) Fri Dec 2 12:22:40 2016: plik wykonywalny: / usr / lib / xorg / Xorg (wiersz poleceń "/ usr / lib / xorg / Xorg -core: 3 -seat seat0 -auth / var / run / lightdm / root /: 3 -nolisten tcp vt10 -novtswitch ")
  BŁĄD: apport (pid 19659) Fri 2 grudnia 12:22:40 2016: is_closing_session (): brak DBUS_SESSION_BUS_ADDRESS w środowisku
  BŁĄD: apport (pid 19659) Fri Dec 2 12:22:40 2016: ten plik wykonywalny już rozbił się 2 razy, ignorując

Myślę, że jest to powiązane, ponieważ czasami po zmianie użytkownika widzę komunikat o błędzie, a czasami słyszę dźwięk komunikatu o błędzie.

    
zadawane Kobi 16.11.2016, 19:47
źródło

1 odpowiedź

1

Spróbuj przejść do ustawień / wyświetlacza i sprawdź, czy jest więcej niż jeden monitor, a jeśli tak, wyłącz monitory, które nie są w użyciu.

    
odpowiedział joao 05.07.2017, 17:31
źródło

Przeczytaj inne pytania na temat tagów