Dlaczego qemu-system-x86 zajmuje 100% mojego procesora?

8

Zmieniłem mój stary laptop na nowy, ale nie rozumiem, dlaczego używanie obu menadżerów virt% qemu-system-x86 na 100% ma 100% mocy procesora podczas uruchamiania vm, podczas gdy na starym nie.

Polecenie:

lscpu

ma to wyjście:

Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    2
Core(s) per socket:    2
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 69
Stepping:              1
CPU MHz:               754.000
BogoMIPS:              5187.74
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              4096K
NUMA node0 CPU(s):     0-3

Podczas mojego starego komputera używa tylko 15% -30% procesora. Aktywowałem również kvm z BIOS-u, ale nic się nie zmienia: nadal używa 100%.

Polecenie górne daje mi:

PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
3410 libvirt+  20   0 3641892 902428  10332 S 101,4 11,2   1:03.36 qemu-system-x86

Jak mam kontynuować?

    
zadawane Riccardo Magrini 23.12.2014, 23:58
źródło

1 odpowiedź

3

Czy próbowałeś użyć właściwego akceleracji dla qemu?
Takie jak:

qemu-system-x86_64  -machine accel=kvm [...]  

Ten przełącznik może sprawić, że Twój komputer będzie korzystać z wirtualizacji sprzętu (zużycie procesora spada do nieistotnego wtedy)

    
odpowiedział novelty_waves 10.01.2015, 02:21
źródło

Przeczytaj inne pytania na temat tagów