Klucze głośności działają w jedności, ale nie w xfce4

20

Moje klawisze głośności nie działają w xfce. Kiedy ich użyłem, pokazuje wskazanie na ekranie, że głośność się zmienia, ale głośność się nie zmienia (tak samo jest z klawiszem wyciszenia).

Dziwne jest to, że kiedy przechodzę z xfce do ubuntu, klawisze działają teraz poprawnie.

Nie wiem, czy to ma znaczenie, ale mam kartę dźwiękową w moim komputerze.

Jak ustawić klawisze głośności w Xfce?

    
zadawane skeept 15.05.2012, 18:26
źródło

8 odpowiedzi

14

To wciąż jest zepsute w 12.10. Możesz to naprawić, instalując mikser xfce4, a następnie ręcznie wybierając miksery do sterowania nim - a następnie wchodząc do edytora ustawień xfce4 i wpisując nazwę "aktywnej karty". Przycisk wyciszania nadal nie działa poprawnie, możesz wyciszyć, ale nie wyłączyć dźwięku z nim. Cała reszta działa, włączając w to powiadomienia na ekranie. To naprawdę trudne, aby wszystko działało, więc otworzyłem błąd: link

Dokładniej, w mikserze xfce4 chcesz wyglądać mniej więcej tak:

Powinno to pokazywać tylko główną kontrolę głośności twojej karty dźwiękowej. Musisz wybrać kartę dźwiękową u góry, a następnie kliknąć "Wybierz sterowanie ...", aby dodać elementy sterujące. Następnie w edytorze ustawień xfce4 musisz ustawić "aktywną kartę" w ten sposób:

Pod "kartami dźwiękowymi" zobaczysz listę każdej karty dźwiękowej, do której dodano miksery. Prawdopodobnie będziesz mieć wiele kart, więc może zająć trochę prób i błędów, aby znaleźć właściwy. Musisz skopiować nazwę poprawnej karty z "kart dźwiękowych" na "aktywną kartę" - będzie to mikser kontrolowany przez przyciski głośności.

    
odpowiedział Alistair Buxton 03.12.2012, 01:20
źródło
5

xfce4-volumed działa tylko dla mnie, gdy nie działa w trybie demona. Klucze woluminu działają dla mnie po uruchomieniu tego polecenia, aby zabić istniejące procesy wolumowane i uruchomić nowy, który nie działa w trybie demona:

kill 'pidof xfce4-volumed' ; mkdir -p /tmp/volumed && cd /tmp/volumed && nohup xfce4-volumed --no-daemon &

To uruchamia proces używając nohup, więc terminal, w którym uruchomisz tę komendę, może zostać zamknięty bez zabicia procesu.

    
odpowiedział Stephen Ostermiller 20.02.2014, 22:52
źródło
4

Te klawisze głośności są oparte na gnome ... Albo oparte na jedności, czy cokolwiek ... Musisz stworzyć niestandardowe skróty klawiaturowe w gui ustawień klawiatury, aby zmniejszyć, zwiększyć i wyciszyć głośność ... Aby zwiększyć głośność, polecenie "amixer set master 5% +" dla zmniejszenia głośności "amixer set master 5% -" do wyciszania "przełącznika głównego amixer"

    
odpowiedział Arpit Roopchandani 19.05.2012, 09:05
źródło
1

Miałem ten sam problem w Xubuntu 12.04, chociaż nie wiem, czy działałoby w Unity, ponieważ mam tylko Xfce4. W terminalu wpisz:

$ xfconf-query -c xfce4-mixer -p /active-card -s xfconf-query -c xfce4-mixer -p /sound-card

Źródło: link

    
odpowiedział MrPink 07.06.2012, 01:44
źródło
1

Jeśli jest to tymczasowy problem, tak jak w moim przypadku, po prostu zrób to w linii poleceń:

killall xfce4-volumed && xfce4-volumed

    
odpowiedział Felipe 17.12.2015, 17:56
źródło
0

Rozwiązałem problem zmieniając parametr "Aktywna karta" w edytorze ustawień xfce4

Mam dwie karty dźwiękowe (jedno HDMI i drugie normalne), a wybrana karta różni się od normalnej karty, której używałem.

    
odpowiedział Damiano 30.12.2012, 17:19
źródło
0

Miałem również ten bardzo dziwny problem, mogłem dostosować suwak głośności w menu i nic by to nie dało. Ponadto, jeśli spróbuję dostosować go za pomocą mojej klawiatury, suwak przesunie się, ale nic nie zmieni się wraz z rzeczywistą głośnością.

Naprawiłem to, przechodząc do PulseAudio Volumne Control . W panelu Output Devices możesz zobaczyć wszystkie opcje karty dźwiękowej. Stamtąd upewniłem się, że port został ustawiony na Analog Output. W twoim przypadku może to być HDMI lub słuchawki w zależności od miejsca, w którym chcesz dźwięk. Następnie wybierz opcję "Ustaw jako rezerwową". Wygląda jak zielony znacznik wyboru.

Ja nie trzeba zainstalować xfce4-mixer , aby to działało.

    
odpowiedział John 27.12.2014, 21:27
źródło
0

W Settings > Settings Manager > Keyboard > Applications Shortcut :

  • dodaj amixer set Master 3+ , aby zwiększyć głośność
  • dodaj amixer set Master 3- , aby zmniejszyć głośność
  • dodaj amixer -D pulse set Master Playback Switch toggle , aby wyciszyć / wyłączyć dźwięk
odpowiedział dr0i 09.03.2017, 08:53
źródło

Przeczytaj inne pytania na temat tagów