Chcę zainstalować libssl.0.9.8

20

Próbuję zainstalować program utorrent, a kiedy wykonuję program, otrzymuję

./utserver: error while loading shared libraries: libssl.so.0.9.8: cannot open shared object file: No such file or directory

Od wczoraj nawiguję na różnych forach i nie znalazłem nic przydatnego do tej pory, więc proszę powiedz mi, jaki jest problem?

    
zadawane Muhammad Jawabreh 08.11.2011, 21:05
źródło

4 odpowiedzi

16

Generalnie powinieneś szukać oprogramowania za pośrednictwem centrum oprogramowania lub jeśli podoba Ci się wiersz poleceń, możesz użyć apt-cache search . W tym przypadku pojawił się następujący pakiet (11.10): libssl0.9.8

Możesz spróbować go zainstalować ( sudo apt-get install libssl0.9.8 ). Jeśli to nie pomoże, możesz nam powiedzieć, której wersji ubuntu używasz.

    
odpowiedział xubuntix 08.11.2011, 21:32
źródło
7

Jeśli używasz 11.10 (od kiedy o tym nie wspomniałeś), masz libssl1.0.0 , który jest wyższy niż 0.9.8. Każdy program, który wymaga 0.9.8, będzie w stanie obsłużyć wersje powyżej tego.

Jeśli NIE masz 11.10, masz kilka sposobów:

  1. Przejdź do strony OpenSSL: link i obserwuj instalacje.

  2. Przejdź do pakietów Ubuntu i pobierz tam plik .DEB: link

  3. Przejdź do pakietów Debiana i pobierz stąd plik .DEB: link

  4. Zainstaluj go przez apt-get lub aptitude :

    • sudo apt-get install libssl0.9.8 - dla wersji 0.9.8
    • sudo aptitude install libssl0.9.8 - dla wersji 0.9.8
    • sudo apt-get install libssl1.0.0 - Dla wersji 1.0.0
    • sudo aptitude install libssl1.0.0 - Dla wersji 1.0.0
odpowiedział Luis Alvarado 08.11.2011, 21:35
źródło
7

W wersji 64-bitowej Ubuntu 12.04 działało, aby zainstalować 32-bitową wersję:

sudo apt-get install libssl0.9.8:i386

Ale oczywiście, kiedy jesteś 32-bitowym Ubuntu, to powinno działać (bez :i386 ):

sudo apt-get install libssl0.9.8
    
odpowiedział ayke 11.02.2013, 00:44
źródło
0

Po prostu spróbuj wykonać te kroki, gdy potrzebujesz go dla CAV dla Linuxa.

Jeśli próbowałeś już zainstalować cav, ale wystąpił błąd z libssl0.9.8:

  1. sudo apt-get --purge remove cav-linux
  2. Usuń wszystkie libssl0.9.8 z / z Synaptic
  3. sudo apt-get clean
  4. sudo apt-get autoremove
  5. sudo aptitude install libssl0.9.8

, a następnie zainstaluj normalny sposób.

  1. Utwórz katalog /opt/COMODO

    Skopiuj tam plik kaw:

    cd /opt/COMODO
    sudo dpkg -i cav-linux_1.1.268025-1_amd64.deb
    
  2. Pobierz sterownik i odbuduj sterownik

    skopiuj je do /opt/COMODO

    uruchom instalację po zakończeniu:

    sudo /opt/COMODO/post_setup.sh
    
  3. Wykonaj tę operację tylko wtedy, gdy pojawi się błąd, że moduły RedirFS nie są zainstalowane

    sudo bash /opt/COMODO/fix_rebuild_driver.sh
    sudo /opt/COMODO/post_setup.sh
    
  4. Reboot

odpowiedział JDoerr 28.08.2016, 10:10
źródło

Przeczytaj inne pytania na temat tagów