Napotkano błędy podczas przetwarzania: man-db

20

Otrzymuję ten błąd, gdy używam apt-get upgrade & apt-get autoremove i na każdym apt-get [Something].. oraz gdy próbuję też zainstalować aplikacje:

Errors were encountered while processing:
man-db
E: Sub-process /usr/bin/dpkg returned an error code (1)
    
zadawane R9TySix 15.02.2012, 18:45
źródło

6 odpowiedzi

15

Przeczytaj komentarze poniżej. To może być niebezpieczne polecenie do uruchomienia w systemie i utworzenia stanu nieodzyskiwalnego. (linie zostały skomentowane, aby uniemożliwić kopiowanie i wklejanie sysadmin'ing).

Proste i działa próbowałem!

sudo -s
# cd /var/cache/debconf
# rm *.dat
apt-get update && apt-get upgrade

Ciesz się;)

    
odpowiedział ucefkh 04.10.2013, 03:40
źródło
12

Żadne rozwiązanie wymienione w odpowiedziach nie działało dla mnie i próbowałem rozwiązania wspomnianego tutaj na forach Ubuntu , wykonując polecenie

sudo dpkg -i --force-all [deb file path]

i to działało.

    
odpowiedział Ravindra Gullapalli 29.03.2013, 00:49
źródło
6

wspólna odpowiedź wiki - rozwiązana przez OP

Ten problem został rozwiązany przez uruchomienie następującego polecenia terminala:

sudo dpkg-reconfigure -phigh -a
    
odpowiedział fossfreedom 27.02.2013, 10:14
źródło
4

Możesz również chcieć wiedzieć, że możesz użyć dpkg --audit , aby zobaczyć, jaki jest faktyczny problem.

Jeśli wynik jest podobny do:

The following packages are in a mess due to serious problems during installation. 
They must be reinstalled for them (and any packages that depend on them) 
to function properly:
  gcdemu A GNOME panel applet to control CDEmu daemon

The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
 cdemu-daemon CDEmu daemon
 cdemu-client A simple command-line client to control CDEmu daemon

The following packages are only half configured, probably due to problems
configuring them the first time. The configuration should be retried using
dpkg --configure <package> or the configure menu option in dselect:
 transmission-daemon lightweight BitTorrent client (daemon)
 vhba-dkms VHBA virtual host bus adapter module

Można uruchomić polecenie: dpkg --configure <packagename>

 dpkg --configure cdemu-daemon

Aby

Reconfigure an unpacked package. 
If -a  or  --pending  is  given instead of package, all unpacked but unconfigured
packages are configured.

Ponadto możesz użyć:

sudo apt-get -f install
sudo apt-get --reinstall install gcdemu

Aby naprawić pakiety, które są w bałaganie.

Przykłady z tego miejsca: link

    
odpowiedział First Name 05.09.2015, 00:08
źródło
3

Musisz uruchamiać te komendy za pomocą sudo, które je poprzedzają, aby można je było wykonywać za pomocą poświadczeń superużytkowników. Przykład:

sudo apt-get autoremove "NAME OF PACKAGE HERE"
    
odpowiedział Scott Stookey 15.02.2012, 18:55
źródło
1

Jeśli usunąłeś /var/cache w błędnej próbie oczyszczenia (tak jak ja), może to rozwiązać problem (dla mnie):

sudo mkdir /var/cache/debconf
    
odpowiedział Matthias Braun 15.03.2014, 15:01
źródło

Przeczytaj inne pytania na temat tagów