Jedność się nie ładuje, nie ma Launchera, nie pojawia się Dash

533

Kiedy się loguję, nic się nie dzieje.

Prezentuję moją tapetę pulpitu.

Bez dash, bez Launchera, nic.

    
zadawane jrg 14.12.2010, 18:24
źródło

30 odpowiedzi

464
  

Ta odpowiedź dotyczy wersji Ubuntu z uruchomionym Compiz.

     

Ta odpowiedź zakłada, że ​​Unity jest uruchamiane przez Compiz. Jeśli nie masz zainstalowanego kompilatora ta odpowiedź nie dotyczy ciebie.

Musisz ponownie włączyć wtyczkę Unity. Problem polega na tym, że jest to dolegliwość, ponieważ nie masz teraz żadnej graficznej metody, aby to zrobić. A więc:

  1. Spróbuj otworzyć terminal za pomocą Ctrl + Alt + T .
    To może nie działać, ale możesz kliknąć prawym przyciskiem myszy na pulpicie i wybierając "Otwórz terminal tutaj". W przeciwnym razie możesz zmienić "twardy" terminal, naciskając Ctrl + Alt + F1 i zaloguj się.

  2. Zainstaluj compizconfig-settings-manager , uruchamiając

    sudo apt-get install compizconfig-settings-manager
    
  3. Następnie uruchom go w następujący sposób:

    DISPLAY=:0 ccsm &
    

    Pierwsza część mówi terminalowi, na którym chcesz go załadować (inaczej nie będzie miał pojęcia).

  4. Jeśli przełączyłeś się na TTY w kroku 1, przełącz się z powrotem na serwer graficzny, naciskając Ctrl + Alt + F7 (lub Ctrl + Alt + F8 czasami).
    Tam powinien pojawić się Menedżer ustawień CompizConfig.

  5. Znajdź wtyczkę Unity. Odblokuj to. Zostaniesz zapytany "Ubuntu Unity Plugin wymaga wtyczki OpenGL. Włącz Ubuntu Unity Plugin / Enable OpenGL"

  6. Wszystko powinno zacząć życie, ale jeśli nie, może być konieczne ponowne uruchomienie. Możesz to zrobić, przechodząc z powrotem do terminala i uruchamiając sudo reboot .

odpowiedział Oli 08.11.2011, 00:23
źródło
165

Dobre rozwiązanie dla mnie (rozwiązał ten sam problem):

w terminalu:

export DISPLAY=:0   
sudo dconf reset -f /org/compiz/

a następnie

setsid unity
    
odpowiedział user155373 04.05.2013, 02:50
źródło
72

W 13.04 i 14.04:

unity --replace jest przestarzałe. Zamiast tego użyj:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Uruchom ponownie, jeśli nie zadziała od razu.

    
odpowiedział Brandon Bertelsen 27.04.2013, 04:39
źródło
60

Dla 12.10 i poniżej:

Naciśnij Ctrl + Alt + T dla terminala i uruchom ccsm , a następnie ponownie włącz wtyczkę 'Unity'.

Możesz również uruchomić unity --replace .

    
odpowiedział xyzzyman 02.10.2011, 04:33
źródło
51

Warto sprawdzić, czy sterownik karty graficznej jest skonfigurowany do używania przyspieszenia sprzętowego i jest skonfigurowany do korzystania z OpenGL. Spróbuj przeszukać Pytaj o Ubuntu i Ubuntu Forums, aby uzyskać informacje dotyczące twoich układów GPU i smaku Ubuntu. Dla użytkowników grafiki hybrydowej zobacz ostatnią sekcję "Grafika hybrydowa" poniżej.

Możesz uruchomić compizconfig-settings-manager i upewnij się, że wtyczka Unity jest zaznaczona (patrz Jakie są niektóre problemy z CCSM i dlaczego miałbym tego uniknąć? ).

Dla wersji 12.04 i nowszej

  1. Zmień na tty1 , naciskając Ctrl + Alt + F1 i zaloguj się.

  2. Zainstaluj compizconfig-settings-manager , uruchamiając

    sudo apt-get install compizconfig-settings-manager
    
  3. Następnie uruchom go, wykonując to:

    export DISPLAY=:0
    ccsm
    

    Pierwsza część mówi terminalowi, na którym chcesz go załadować (inaczej nie będzie miał pojęcia).

  4. Naciśnij Ctrl + Alt + F7 (lub Ctrl + Alt + F8 czasem), aby powrócić do ekranu graficznego, na którym powinien się znajdować ekran CompizConfig Settings Manager.

  5. Znajdź wtyczkę Unity. Odblokuj to.

  6. Wszystko powinno zacząć życie, ale jeśli nie, może być konieczne ponowne uruchomienie. Możesz to zrobić, cofając się do tty1 i uruchamiając sudo reboot .

Jeśli jedność nadal się nie ładuje spróbuj:

dconf reset -f /org/compiz/
unity --reset-icons &disown

Uruchom ponownie, jeśli nie zadziała od razu.

Dla 11.10 i starszych

Jeśli masz nadzieję na TTY ( Ctrl + Alt + F1 do F6 ) i uruchom:

DISPLAY=:0 unity --replace

Przywróci Unity z powrotem na TTY 7 ( Ctrl + Alt + + F7 ).

Możesz także spróbować po prostu:

DISPLAY=:0 unity

Ale to nie zadziała, jeśli menadżer systemu Windows jest już uruchomiony na ekranie 0 (spowoduje to błąd, po prostu użyj unity --replace w tym przypadku).

Jeśli Unity absolutnie odmówi ponownego uruchomienia spróbuj tego:

Zainstaluj gnome-panel :

sudo apt-get install gnome-panel

Niż go uruchom na wyświetlaczu 0:

DISPLAY=:0 gnome-panel

Powinieneś wtedy mieć panele w stylu Gnome 2 na pulpicie, których możesz użyć do wylogowania.

Hybrydowa grafika

Niektóre bardzo użyteczne informacje i dalsze czytanie dla użytkowników grafiki hybrydowej można znaleźć tutaj .

Gdy układy GPU są odpowiednio skonfigurowane do akceleracji 3D i OpenGL, możesz:

  1. Zainstaluj sterowniki Nvidii z linku :

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    lub:

    Naprawdę wolałbym stabilny PPA , ale nie wydaje się mieć pakietów jeszcze za 13.04 . Aktualizacja: wydaje się, że są one dostępne od 25 września. Chciałbym zainstalować ten stabilny PPA - możesz spróbować, ale nie przetestowałem go.

    Sterowniki Nvidii dostarczone przez Ubuntu zostały już zainstalowane i po prostu zainstalowałem je z tego PPA, dodając je i wykonując aktualizację pakietu, używając update-manager .

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    
  2. Zainstaluj Bumblebee z linku

    AKTUALIZACJA: Od 6 października, ppa:xorg-edgers/ppa wydaje się również zawierać trzmiel. Więc jeśli instalujesz z tego PPA, możesz spróbować pominąć dodatek Bumblebee PPA i zainstalować go zamiast tego.

    Jeśli wybrałeś stabilny PPA w kroku 1, zainstaluj stabilny PPA Bumblebee w następujący sposób:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. AKTUALIZACJA: Po dodaniu PPA zaktualizuj listę pakietów:

    sudo apt-get update
    

    Jeśli masz już zainstalowane sterowniki nvidia ze standardowych repozytoriów Ubuntu, po prostu uaktualnij, aby pobrać nową wersję z repozytorium wybranego w kroku 1:

    sudo apt-get upgrade
    sudo apt-get install bumblebee
    
  4. Wykonaj następujące polecenia, aby "naprawić" Unity (z brandon-bertelsen na Unity nie ładuje się, nie ma Launchera, nie pojawia się Dash ):

    dconf reset -f /org/compiz/
    unity --reset-icons & disown
    
odpowiedział Mark Shuttleworth 27.12.2010, 13:45
źródło
32

Najłatwiej to zrobić, naciskając klawisze Ctrl + Alt + T , aby uzyskać terminal, a następnie:

rm -rf ~/.compiz-1 ~/.config/compiz-1

i twoja sesja jedności powróci na twoich oczach ..

Ta technika jest lepsza niż ponowne uruchamianie ccsm, ponieważ możesz przejść do stanu błędu OP bez nawet przypadkowego odznaczenia jedności w ccsm; możesz to zrobić po prostu przez przypadkowe naciśnięcie przycisku "preferencje" w ccsm.

    
odpowiedział achiang 10.11.2011, 06:55
źródło
24

Też miałem ten problem. Rozwiązałem go, usuwając zawartość pliku ~ / .config / compiz-1 / compizconfig i ponownie się loguję.

rm -rf ~/.config/compiz-1/compizconfig/*
    
odpowiedział dome cs 30.10.2011, 07:23
źródło
21

Miałem dokładnie ten sam problem.

Jeśli masz zainstalowany program Menedżer ustawień konfiguracji Compiz, może to oznaczać, że wtyczka Unity Desktop jest wyłączona.

Zaloguj się na pulpicie Unity 2D i sprawdź, czy jest włączony w CCSM w ten sposób,

Unity Shell nie załaduje się na domyślnym pulpicie, jeśli pole wyboru nie zostanie zaznaczone, a sesja pojawi się w obrazie.

    
odpowiedział Mark Rooney 22.10.2011, 09:09
źródło
19

Programiści zawsze naprawiają błędy, więc alternatywą jest czekać i śledzić postępy w naprawianiu błędów ( subskrybować do rozwoju Unity w Launchpad ).

  1. Naciśnij Ctrl + Alt + F2 .

  2. Zaloguj się.

  3. Uruchom sudo shutdown -r now w terminalu.

  4. Na ekranie logowania po ponownym uruchomieniu systemu wybierz Unity 2D (na razie) klikając prawym przyciskiem myszy ikonę koła łańcuchowego.

  5. Poczekaj na poprawkę dla Unity 3D / Ubuntu 11.10 (np. na tydzień).

  6. Zaktualizuj system, aby uzyskać poprawkę; w terminalu sudo apt-get update && sudo apt-get upgrade .

AKTUALIZACJA: udało mi się rozwiązać ten problem, używając ccsm , z logowania Unity 2D.

(Zostało to zaadaptowane z tego posta na forum Ubuntu .)

  1. Na ekranie logowania wybierz Unity 2D i zaloguj się.

  2. Zainstaluj ccsm (Menedżer ustawień CompizConfig), uruchamiając terminal: sudo apt-get install compizconfig-settings-manager compiz-fusion-plugins-extra .

  3. Rozpocznij ccsm i wybierz kategorię Pulpit . Włącz Ubuntu Unity Plugin ; jeśli zostaniesz poproszony o rozwiązanie konfliktów, wybierz przycisk ŚREDNI na wszystkie konflikty. Po zakończeniu wykonaj ccsm .

  4. Ponownie uruchom, wybierz Unity (3D) i zaloguj.

odpowiedział david6 15.10.2011, 23:47
źródło
13

Mam Asus U36SD z konfiguracją "Optimus" (Intel + Nvidia). Miałem Ubuntu 12.04 działa dobrze, ale uaktualnienie do 12.10, problem ten pojawił się i utrzymywał w 13.04. Udało mi się to naprawić, wykonując następujące kroki:

  1. Zainstaluj sterowniki Nvidii z linku .

    LUB:

    Naprawdę wolałbym stabilny PPA na stronie link , ale wydaje się, że nie ma pakietów na 13.04 jeszcze . Aktualizacja: wydaje się, że są one dostępne od 25 września. Chciałbym zainstalować ten stabilny PPA - możesz spróbować, ale nie przetestowałem go.

    Sterowniki Nvidii dostarczone przez Ubuntu zostały już zainstalowane i po prostu zainstalowałem je z tego PPA, dodając je i wykonując aktualizację pakietu, używając update-manager . AKTUALIZACJA:

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    (co zrobiłem) lub:

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    

    (stabilne wydanie także za 13,04 - nie testowane przeze mnie).

  2. Zainstaluj Bumblebee z linku

    AKTUALIZACJA: Od 6 października ppa: xorg-edgers / ppa prawdopodobnie zawiera także trzmiel. Więc jeśli instalujesz z tego PPA, możesz spróbować pominąć dodatek Bumblebee PPA i zainstalować go zamiast tego.

    Jeśli wybrałeś stabilny PPA w kroku 1, zainstaluj stabilny PPA Bumblebee w następujący sposób:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. AKTUALIZACJA: Po dodaniu PPA zaktualizuj listę pakietów:

    sudo apt-get update
    

    Jeśli masz już zainstalowane sterowniki nvidia ze standardowych repozytoriów Ubuntu, po prostu uaktualnij, aby pobrać nową wersję z repozytorium wybranego w kroku 1:

    sudo apt-get upgrade
    

    Zainstaluj Trzmiel

    sudo apt-get install bumblebee
    
  4. Wykonaj następujące polecenia, aby "naprawić" Unity (z brandon-bertelsen na Unity nie ładuje się, nie ma Launchera, nie pojawia się Dash ):

    dconf reset -f /org/compiz/ 
    unity --reset-icons &disown
    
odpowiedział Thomas Arildsen 02.05.2013, 12:45
źródło
12

Oryginalny plakat powielonego pytania, rozwiązany w edycji własnego pytania:

  

Rozwiązanie znalezione: Usuń .Xauthority w moim domu (lub zmień jego nazwę)

    
odpowiedział mateo_salta 08.08.2012, 22:41
źródło
10

Dla 13.10:

Aby upewnić się, że wszystko jest zainstalowane:

sudo apt-get install --reinstall unity ubuntu-desktop

Następnie przeładuj wszystko:

dconf reset -f /org/compiz/ && unity --reset-icons &disown

Właśnie próbowałem tego i to działa!

Źródło:

link

Jeśli wszystko inne zawiedzie:

Pamiętaj, zawsze rób kopie zapasowe! Jednak czasami świeża instalacja jest dobra, przeinstalować Ubuntu?

    
odpowiedział Jared Burrows 06.12.2013, 01:07
źródło
10

To też mi się przydarzyło w Ubuntu 16.04 po aktualizacji pakietów jedności i compiz. Żadna z powyższych nie zadziałała.

Jedynym sposobem, w jaki znalazłem wyrzutnie i myślniki, było usunięcie (podczas gdy NIE zalogowałem się do Unity) katalogu .cache w moim domu.

    
odpowiedział lorenzo-bettini 20.09.2016, 09:27
źródło
9

Wygląda na to, że jest problem z 12.04 Unity 3D i aktualnymi sterownikami Nvidii.

Zobacz ten post (Unity 3d nie działa po instalacji 12.04) , aby dowiedzieć się, jak obejść problem.

Mam 32-bitowy procesor Pentium 4 3.06 GHz Compaq D520SFF, z Nvidia GeForce 6200, z jądrem 3.2.0-24-generic-pae, i miał dokładnie ten sam problem (2D działa, 3D nie), i obniżenie poziomu sterowników Nvidii sprawiło, że 3D działa dla mnie za kilka minut.

    
odpowiedział Heimdall 01.05.2012, 01:38
źródło
8

W przypadku ikon jest to spowodowane Nautilusem. Napisz nautilus & w terminalu, nie zamykaj go , a ikony wrócą.

EDIT 10/10/2013 : w przypadku Nautilusa możesz również wpisać Alt + F2 , aby otworzyć wiersz polecenia Unity i wpisać nautilus w globalnym wyszukiwaniu / monitorze CLI. Otworzy się eksplorator plików. Możesz go zamknąć, jeśli chcesz.

    
odpowiedział air-dex 26.12.2012, 16:14
źródło
8

Miałem podobny problem:

jedność z 14.04 w połączeniu z IBM Notes9 spowodowała dziwne zachowanie (kliknięcia myszy przestałyby działać). Moim rozwiązaniem było otwarcie terminalu i ponowne uruchomienie jedności poprzez wpisanie unity & .

Ostatnim razem, gdy to zrobiłem, całkowicie zepsuło to jedność - nie ma nic, nie ma wyrzutni, nie ma niczego. Chyba wypróbowałem KAŻDĄ sugestię wymienioną na tej stronie - nic z tego nie pomogło.

Ale współpracownik w końcu otrzymał odpowiedź, która zadziałała dla mnie:
Zainstalowałem narzędzie do korekty jedności; niż uruchomiłem unity-tweak-tool --reset-unity i zrestartowałem.

Potem jedność wróciła do życia. Oczywiście wszystkie poprzednie zmiany konfiguracji do jedności minęły, ale właśnie o to chodzi w --reset-unity .

Zaletą tego rozwiązania jest to, że wymaga on tylko dodania pojedynczego pakietu i ponownego wprowadzenia zmian w konfiguracji jedności - ale nie trzeba resetować kompu, instalować ccsm ani wykonywać innych długich czynności.

Aktualizacja:

inne rozwiązanie, które uważam za bardzo pomocne w dzisiejszych czasach, pochodzi z tutaj - punkt : czasami musisz usunąć (lub jeszcze lepiej: pobrać "działającą" kopię zapasową) pliku ~ / .config / dconf / user.

    
odpowiedział GhostCat 04.06.2014, 12:21
źródło
6

Jeśli masz nadzieję na tty ( Ctrl + Alt + F1 do F6 ) i uruchom:

DISPLAY=:0 unity --replace

Przywróci Unity z powrotem na tty 7 ( Ctrl + Alt + + F7 ).

Możesz także spróbować po prostu:

DISPLAY=:0 unity

Ale to nie zadziała, jeśli menadżer systemu Windows jest już uruchomiony na ekranie 0 (spowoduje to błąd, po prostu użyj unity --replace w tym przypadku).

Jeśli Unity absolutnie odmówi ponownego uruchomienia spróbuj tego:

Zainstaluj gnome-panel :

sudo apt-get install gnome-panel

Niż go uruchom na wyświetlaczu 0:

DISPLAY=:0 gnome-panel

Powinieneś wtedy mieć panele w stylu Gnome 2 na pulpicie, których możesz użyć do wylogowania.

Uważam Unity za naprawdę błędną 13.04 z moją kartą Nvidii .. YMMV.

    
odpowiedział Seth 19.05.2013, 20:07
źródło
5

Miałem około 3 razy tam, gdzie potrzebowałem Ctrl + Alt + F1 , aby nie stracić pracy i pomieszało ... Mam również NVIDIA. Chciałbym zasugerować to:

Ctrl + Alt + F1 (ok, pusty ekran) Wpisz swój login, naciśnij Enter, a następnie hasło (wszystko na pustym ekranie) wpisz teraz:

sudo startx -- :1

będzie musiał ponownie wpisać hasło i Enter to otworzy sesję X w Ctrl + Alt + F8 (przeskoczy do niej automatycznie) teraz utwórz nowy pusty plik tekstowy o nazwie runBash.sh i wpisz go:

bash

zapisz go, zmień jego uprawnienia do pliku wykonywalnego i uruchom go, otrzymasz terminal odciążający, który sprawi, że będziesz pamiętać, dlaczego Linux jest dobry! : D

po zakończeniu, pamiętaj o Ctrl + Alt + F1 , naciśnij Ctrl + C (zakończy nową sesję X), wpisz exit, Enter, zakończy sesję terminalu (pusty ekran). jeśli myślisz, że przegapiłeś wpisanie wyjścia, po prostu naciśnij Ctrl + C i wpisz ponownie, nie rób tego zbyt szybko.

więc możesz go poprawić, stworzyć skrypt, który pozwoli ci pisać tak mało, jak to możliwe, ale i tak będziesz musiał pisać dużo, gdy ekran jest pusty, ale jest lepszy niż nic:)

Ciągle szukam ostatecznego rozwiązania Ctrl + Alt + F1 właściwego rozwiązania Ubuntu 12.04 + nvidia.

    
odpowiedział Aquarius Power 28.05.2012, 01:39
źródło
4

Jeśli używasz karty graficznej przyspieszenia obok domyślnej karty graficznej, prawdopodobnie jest to spowodowane instalacją sterowników. Kilka aktualizacji sterowników kart graficznych przyspieszających w systemach z dwiema kartami graficznymi wykazuje tendencję do niestabilnego zachowania w niektórych systemach. Mam kartę Nvidia i kartę Intel. Kiedyś instalowałem sterowniki Nvidii. Launcher i panel znikną z pulpitu. Jeśli używasz karty Nvidia, instalacja Bumblebee może być tymczasowym rozwiązaniem: link

    
odpowiedział user153634 01.05.2013, 12:46
źródło
4

Pierwsza odpowiedź działa dobrze, ale muszę zainstalować Unity:

sudo apt-get install unity

następnie uruchom:

ccsm

i włącz Unity:)

    
odpowiedział sobi3ch 26.11.2013, 02:22
źródło
4

Miałem ten sam problem pod 12.04. Jedność była powolna w moim starym GPU, więc od miesięcy używałem Unity 2d jako mojego komputera. Bez wyraźnego powodu nagle odmówił wyświetlania startera i paska tytułu (dla wszystkich użytkowników). Ponowne włączanie Unity w CCSM, jak sugerowano tutaj, było częścią rozwiązania, ale żaden z innych środków sugerowanych tutaj, tam lub w kilku innych powiązanych wątkach, w tym, ale nie ograniczając się do:

  • Ponowna instalacja jedności

  • Ponowna instalacja pulpitu ubuntu

  • Usuwanie wszystkich istotnych informacji konfiguracyjnych (np. compiz, gconf itp.)

pomógł mi całkowicie rozwiązać te objawy w 12.04 (64-bitowy).

unity --reset

nie byłoby dla mnie skuteczne. Po dostarczeniu różnych komunikatów o błędach i komunikatach informacyjnych zawsze będzie to:

Setting Update "run_key"

jak pokazano w dzienniku opublikowanym w wątku "jedność zniknęła" dla uruchomienia jedności bez argumentów .

Zauważyłem, że komunikat o błędzie został dostarczony przez:

/usr/lib/nux/unity_support_test -p

było podobne do niektórych błędów zgłoszonych przez unity --reset :

błąd podczas ładowania bibliotek współdzielonych: libGL.so.1: nie można otworzyć pliku obiektu współdzielonego: Brak takiego pliku lub katalogu.

Po intensywnych poszukiwaniach znalazłem następujące rozwiązanie:

  • Uzyskaj ścieżkę libGL.so.1 , używając polecenia locate libGL.so.1 .

  • Dodaj link do biblioteki w / usr / lib /, jak pokazano w następującym przykładzie:

    sudo ln -s /usr/lib/i386/mesa/libGL.so.1 /usr/lib
    

    (dzięki uprzejmości JD Bartlett )

  • Uruchom ponownie komputer.

Pozwoliło to nie tylko na uruchomienie programu unity_support_test-p i unity --reset , ale także na uruchomienie Unity 2D. Nie mam pojęcia, co spowodowało moje problemy, ale odkąd utworzyłem linki powyżej (kilka tygodni), nie miałem żadnych dalszych problemów.

    
odpowiedział R B 20.12.2013, 11:42
źródło
4

Kiedy przypadkowo zaktualizowałem system z 12.04 LTS Ubuntu do 13.04, musiałem również stawić czoła tym samym problemom, takim jak brak paska bocznego menu, brak opcji okna, brak możliwości przełączania między aplikacjami ( alt - tab ) i nie mogłem nawet przeciągnąć okien na ekranie. Po wykonaniu tak wielu opcji otrzymałem następujący zestaw poleceń, aby naprawić te problemy.

sudo apt-get remove aspell #may not be relevant
sudo apt-get remove dictionaries-common

restart (możesz użyć sudo reboot )

sudo apt-get install compizconfig-settings-manager
sudo apt-get install dictionaries-common
sudo apt-get install lightdm

restart (możesz użyć sudo reboot )

dconf reset -f /org/compiz/
unity --reset-icons & disown

Rzeczywiście usunąłem aspell z powodu konfliktu zależności. Może to nie mieć żadnej korelacji między tym problemem. Myślę, że ponowne zainstalowanie lightdm i zresetowanie compiz pomogło mi to naprawić.

    
odpowiedział Bunti 16.05.2014, 18:20
źródło
4

Zdarza się, gdy logujesz się za pomocą innego tty i próbujesz, jako ten sam użytkownik, uruchamiać X (za pomocą startx lub initx).

Na przykład, Ubuntu działa w tty7. Z Ctrl + Alt + F1 otwiera się tty1. Zaloguj się jako ten sam użytkownik i uruchom startx. Wróć do tty7, wyloguj się i zaloguj. Dostajesz tylko tapetę na biurko.

Aby rozwiązać problem, wybierz tty1, zaloguj się, usuń plik .Xauthority z katalogu domowego, wyloguj się, zaloguj. Rozwiązany.

    
odpowiedział user85164 27.04.2013, 08:59
źródło
2

Miałem ten sam problem po wykonaniu sudo apt-get install kubuntu-desktop , który z jakiegoś powodu przerwał moją instalację lightdm. Używam tutaj 16.04.

Naciśnij ctrl - alt - F1 , aby dostać się do terminala, a następnie:

sudo service lightdm stop
sudo apt-get remove lightdm
sudo apt-get update && sudo apt-get install lightdm
sudo reboot

To naprawiło to po wielu godzinach wyrywania włosów.

    
odpowiedział localhost 07.10.2016, 17:29
źródło
2

Dla Ubuntu 16.04:

Zresetowałem compizconfig , usuwając jego pamięć podręczną (faktycznie polecenie tworzy kopię zapasową, aby można ją było przywrócić).

Wykonaj następujące polecenia i wyloguj się z hasłami:

mv ~/.cache/compizconfig-1 ~/.cache/compizconfig-backup

setsid unity

Uwaga: Usuwa twoją niestandardową konfigurację Unity.

    
odpowiedział Oleksandr Shpota 09.03.2018, 00:49
źródło
1

Mam ten sam problem i rozwiązany przez użycie pycharm's terminal .

 - Go to my-computer -> user -> share ->  
 - open pycharm and its terminal
 - sudo apt-get update
 - sudo apt-get upgrade 
 - sudo apt-get install --reinstall ubuntu-desktop
    
odpowiedział Muhammad Taqi 02.06.2015, 14:26
źródło
1

Najwyraźniej odłączenie drugiego monitora było poprawką, a następnie udało mi się zainstalować i zaktualizować właściwe sterowniki.

    
odpowiedział user2580915 27.07.2015, 20:08
źródło
1

Próbowałem wielu rozwiązań wymienionych w tym wątku, a także innych. W końcu to zadziałało dla mnie:

dconf reset -f /org/compiz/

wtedy

setsid unity

Dziękuję wszystkim za wniesienie wkładu.

    
odpowiedział Ashu 17.01.2016, 02:00
źródło
1

Dzisiaj natknąłem się na sytuację, w której użytkownik mojego skryptu zdecydował się uruchomić go, umieszczając wywołanie skryptu w swoim pliku $HOME/.profile . W rezultacie Unity nie mogło wystartować.

Skrypty z natury są sekwencyjne, więc .profile zasadniczo czekało na zakończenie skryptu, a Unity nie może się uruchomić, jeśli .profile nie zakończyło się.

Zrobiłem to samo, nazywane skryptem z .profile i otrzymałem ten sam wynik - moja tapeta ekranu logowania pozostała tam, nie pojawiła się myślnik ani program uruchamiający, nie można kliknąć prawym przyciskiem myszy na pulpicie lub wykonać żadnej akcji innej niż zaloguj się do TTY1.

Rozwiązaniem było usunięcie odpowiedniej linii z .profile . Możliwe jest odłączenie polecenia od .profile przy użyciu formularza ampersand, <command> & , ale problem polega na tym, że za każdym razem, gdy użytkownik otwiera terminal lub loguje się do TTY, pojawia się nowa instancja tego polecenia. Dlatego zdecydowanie nie zaleca się uruchamiania programów z .profile , chyba że wiesz, co robisz.

Link do oryginalnego skryptu i dyskusji tutaj: link

    
odpowiedział Sergiy Kolodyazhnyy 28.02.2016, 04:10
źródło
1

Miałem ten problem, próbowałem wielu rzeczy, a nawet umożliwiłem jedność, ale nic nie działało. Najpierw musisz otworzyć TTY (ctrl + alt + F1) i zalogować się. Teraz użyj

    env DISLAY:=0 gnome-terminal        

Zamknij TTY za pomocą ctrl + alt + F7, a następnie użyj (w terminalu)

dconf reset -f /org/compiz/

Następnie użyj

sudo reboot
    
odpowiedział TheEpicstarlord 07.01.2017, 14:09
źródło

Przeczytaj inne pytania na temat tagów