Dziwny częściowy migotanie ekranu po aktualizacji do 14.04

20

Już od kilku tygodni dręczy mnie ten problem. Problem zaczął się po uaktualnieniu do wersji 14.04. Części ekranu są czasami migotliwe, jak pokazano na 2 filmach, które łączę załączam poniżej:

link

link

Próbowałem nagrać to z VLC, ale nagle, kiedy zaczynam nagrywać, ... przestaje migotać :)

Nie mam pojęcia, gdzie mogę zgłosić błąd i z którym pakietem może być związany. Skomentuj, z czym może być powiązany i jak mogę rozwiązać ten problem.

W razie potrzeby opublikuję wszelkie istotne informacje dotyczące pakietów.

Używam nvidia-334 z pakietu xorg edgers ( 334.21-0ubuntu1~xedgers14.04.1 ), ale wypróbowałem też inne i jest to ten sam problem.

    
zadawane Patryk 20.05.2014, 18:17
źródło

5 odpowiedzi

13

To działało dla mnie: link

Włącz Wymuś odświeżanie całego ekranu w opcji odświeżania w Obejściach

Miałem losowe migotanie podobne do tego (np. część strony migotała w Firefoksie (przyspieszenie sprzętowe = włączone), lub ikona pulpitu migotała po odznaczeniu jej) i to wydawało się naprawić ten problem.

Używam sterowników Nvidia 340.58, Lenovo Y500 GT 750m (pojedynczy, brak optymalizacji, IntelHD wyłączony).

    
odpowiedział Lindza 22.11.2014, 16:21
źródło
6

To błąd w Compiz. Jeśli to dotyczy ciebie, powinieneś przejść tutaj i kliknąć "ten błąd dotyczy mnie" .

Istnieje obejście problemu, ale może ono spowolnić system.

Zainstaluj Menedżera ustawień CompizConfig , a następnie przejdź do Composite i wyłącz Unredirect fullscreen windows .

    
odpowiedział nastys 27.05.2014, 20:55
źródło
6

Zainstalowałem sterowniki nvidia-331 (331.38-0ubuntu7) i przez kilka dni nie doświadczyłem żadnego migotania, więc prawdopodobnie wystąpił problem ze sterownikami ( xorg-egders wersja 334 lub ostatnie 337 )

    
odpowiedział Patryk 29.05.2014, 12:15
źródło
4

Pełne instrukcje oparte na innych odpowiedziach tutaj:

  • Zainstaluj Compiz Config, na terminalu wpisz:

    sudo apt-get install compizconfig-settings-manager

  • Z programu uruchamiającego uruchom Menedżer ustawień CompizConfig

  • Zaznacz pole wyboru w "Narzędzia - > Obejścia - > Wymuś odświeżanie pełnoekranowe (zamiana buforów) podczas odświeżania"

To też zadziałało, mam laptopa Dell XPS z Nvidią GT 525m, używając Ubuntu 14.04.

    
odpowiedział Sebastián Ramírez 15.03.2015, 14:06
źródło
-1

Miałem bardzo podobny problem z 2 GTX 680 w SLI i najnowszymi sterownikami NVIDIA na świeżej instalacji ubuntu w RAID-0. Przypomniałem sobie przed kierowcami Nvidii, że ekran jest bardzo solidny i stabilny dzięki nouveau driverom.

Ale po sterownikach Nvidii coś się zepsuło ... i ekran zaczął migotać. Zapamiętałem wybór kroku w instalatorze Nvidia, aby umożliwić instalatorowi wygenerowanie pliku xorgs.conf.

Zmieniłem nazwę pliku xorg.conf na xorg.conf.bad-nvidia, teraz wszystko wygląda pięknie. Po prostu nie potrzebujesz tego xorgs.conf stworzonego przez wykasowane instalatory nvidia.

    
odpowiedział Frustrated Nvidia user 06.08.2014, 17:26
źródło

Przeczytaj inne pytania na temat tagów