Modem 3G USB nie działa w dniu 12.04

18

Po podłączeniu mojego modemu 3G USB do laptopa za pomocą 12.04 nic nie wyświetla się w Network-Managerze. Ten modem działa w wersji 11.10, a modem jest wyświetlany w Network-Managerze, ale nie w 12.04!

Oto wyniki lsusb i usb-devices na dwóch komputerach, jeden z 11.10 i drugi z 12.04:

Ubuntu-11.10:

$ lsusb
    Bus 002 Device 009: ID 1c9e:6061  

$ usb-devices
    T:  Bus=02 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#=  9 Spd=12  MxCh= 0
    D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=1c9e ProdID=6061 Rev=00.00
    S:  Manufacturer=3G USB Modem        ￴￴
    S:  SerialNumber=000000000002
    C:  #Ifs= 4 Cfg#= 1 Atr=a0 MxPwr=500mA
    I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

Ubuntu-12.04:

$ lsusb
    Bus 002 Device 003: ID 1c9e:6061 OMEGA TECHNOLOGY WL-72B 3.5G MODEM

$ usb-devices
    T:  Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
    D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=1c9e ProdID=6061 Rev=00.00
    S:  Manufacturer=Qualcomm, Incorporated
    S:  Product=USB MMC Storage
    S:  SerialNumber=000000000002
    C:  #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
    I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)

Jak pokazuje wynik powyższych poleceń, urządzenie jest wykrywane jako modem w 11.10, ale w 12.04 jest wykrywane jako pamięć USB (urządzenie to zarówno modem 3G, jak i karta USB SD).

Jakakolwiek pomoc?!

    
zadawane Seyed Mohammad 30.05.2012, 07:10
źródło

10 odpowiedzi

22

Po wielu poszukiwaniach i czytaniu na różnych forach znalazłem rozwiązanie mojego problemu. Należy pamiętać, że podczas gdy inne odpowiedzi nie rozwiązały mojego problemu, mogą być pomocne dla osób borykających się z problemami z modemami 3G USB (szczególnie sakis-3g script).

Znalazłem moje rozwiązanie w tym wątku , który szczegółowo opiszę poniżej:

Po podłączeniu modemu USB jest on wykrywany jako pamięć USB. Zgodnie z tym wątkiem, uruchomienie sudo modprobe option może spowodować, że urządzenie zostanie wykryte jako modem. Jeśli nie, zaleca się wykonanie następujących poleceń:

sudo su
echo 1c9e 6061 > /sys/bus/usb-serial/drivers/option1/new_id

gdzie 1c9e 6061 jest identyfikatorem urządzenia uzyskanym z polecenia lsusb . To zadziałało dla mojego urządzenia i zostało wykryte w Network-Manager. Zauważ, że musisz zostać rootem używając sudo su , a uruchomienie polecenia z sudo nie będzie działać.

Aby zautomatyzować różne rzeczy, przedstawiono następujące kroki:

  1. sudo su
  2. nano /usr/bin/usbModemScript i umieść w pliku:

       #!/bin/bash
       echo 1c9e 6061 > /sys/bus/usb-serial/drivers/option1/new_id
    

    Następnie zapisz plik (Ctrl + O) i zakończ nano (Ctrl + X).

  3. chmod +x /usr/bin/usbModemScript

  4. nano /etc/udev/rules.d/option.rules i umieść w pliku:

        ATTRS{idVendor}=="1c9e", ATTRS{idProduct}=="6061", RUN+="/usr/bin/usbModemScript"
        ATTRS{idVendor}=="1c9e", ATTRS{idProduct}=="6061", RUN+="/sbin/modprobe option"
    

    Następnie zapisz plik (Ctrl + O) i zakończ nano (Ctrl + X).

  5. reboot

UWAGA: powinieneś zastąpić wartości 1c9e i 6061 odpowiednimi wartościami ID urządzenia swojego modemu.

Po ponownym uruchomieniu modem powinien zostać wykryty podczas podłączania go do komputera. Oczywiście może tak nie być (ponieważ nie było to dla mnie)! Moje urządzenie nie zostało poprawnie wykryte po pierwszym podłączeniu do komputera. Zamiast tego musiałem odłączyć, a następnie ponownie połączyć, i tym razem został poprawnie wykryty jako modem w Network-Manger. Niektóre osoby mogą również zrestartować usługę menedżera sieci (tak jak ja):

sudo service network-manager restart

=============================================== =================================

Kolejnym potencjalnym rozwiązaniem jest użycie wvdial .

  1. Instalacja: sudo apt-get install wvdial
  2. Podłącz modem do komputera.
  3. Uruchom: sudo wvdialconf /etc/wvdial.conf . Jeśli jest napisane "nie znaleziono modemu", oznacza to, że nie masz szczęścia!
  4. Jeśli modem zostanie znaleziony, uruchom: sudo nano /etc/wvdial.conf i wprowadź informacje o usługodawcy internetowego w razie potrzeby, wypełniając odpowiednie pola. Uruchom man wvdial.conf w oddzielnym terminalu, aby uzyskać informacje o opcjach. Kiedy będziesz gotowy, zapisz plik (Ctrl + O) i wyjdź z nano (Ctrl + X).
  5. Teraz spróbuj się połączyć: sudo wvdial

Aby uzyskać więcej informacji na temat wvdial , przeczytaj stronę podręcznika (to jest man wvdial ).

Mam nadzieję, że to pomoże :)

    
odpowiedział Seyed Mohammad 06.06.2012, 09:25
źródło
5

Mam Huawei E156 HSDPA (3G) USB Stick i zrobiłem to, również zadziałało dla mojego samsung 3g mobile przez kabel usb.

sudo apt-get install wvdial

po zainstalowaniu typu wvdial po linii w terminalu, aby edytować plik wvdial.conf

sudo gedit /etc/wvdial.conf

Wklej do edytora następujące linie:

[Dialer name]
Modem Type = Analog Modem
Phone = *99#
ISDN = 0
Baud = 460800
Username = " "
Password = " "
Modem = /dev/ttyUSB0
Init1 = ATZ
Init2 = at+cgdcont=1,"ip","your Access Point Name"
Stupid Mode = 1

Zawsze, gdy musisz się połączyć, wpisz swój terminal

sudo wvdial name

Teraz będziesz online z niesamowitą prędkością. Myślę, że ta metoda jest mniej czasochłonna i szybsza niż inne metody.

    
odpowiedział gunjan parashar 18.01.2012, 20:58
źródło
2

spróbuj

sudo modprobe usbserial vendor=0x1c9e product=0x6061

I poczekaj chwilę. Zawsze działa dla mnie

    
odpowiedział virpara 30.05.2012, 07:26
źródło
2

czy próbowałeś użyć usb_modeswitch:

link

aby zmienić typ z USB MMC Storage na 3G USB Modem?

    
odpowiedział Steve 05.06.2012, 14:17
źródło
1

Czy zainstalowałeś przełącznik-usb? Ubuntu 10.10 musiał się z tym pogodzić. Spróbuj sprawdzić za pomocą Synaptics, czy zainstalowany jest przełącznik USB. Po zainstalowaniu podłącz modem USB i poczekaj. Na ikonie połączenia pojawi się opcja zapisywania nowych mobilnych łączy szerokopasmowych. Następnie postępuj zgodnie z instrukcjami z okna. Im przy użyciu modemu USB z Ubuntu 10.10 i działa dobrze. =)

    
odpowiedział Wilsonzaizai 23.10.2010, 13:24
źródło
0

Czy znasz markę i model swojego modemu? Huawei, Option lub Sony Ericsson? Niektóre modele Huawei wymagają pewnych ulepszeń. Na stronie w języku duńskim: link możesz pobrać i uruchomić skrypt, który sprawi, że większość modeli Huawei będzie działać. Możesz przetłumaczyć stronę za pomocą google translate; -)

    
odpowiedział Areius 25.10.2010, 11:18
źródło
0

zainstaluj usb-modeswitch i używaj wvdial lub gnome-ppp do łączenia się z Internetem. Będziesz także mógł łączyć się za pomocą menedżera sieci, jeśli zostanie wykryty modem. przełącznik-usb jest sztuczką.

Jeśli twój modem ma dostępne niestandardowe sterowniki, zainstaluj je.

    
odpowiedział srinathhs 25.10.2010, 18:45
źródło
0

Dla tego MODEMU USB spróbuj sakis-3g. Możesz go pobrać: link

    
odpowiedział Octávio Filipe Gonçalves 05.06.2012, 13:39
źródło
0

Po prostu użyj alternatywnego połączenia, pełnej aktualizacji Ubuntu. Połącz ponownie za pomocą Dongg 3g.

I będzie działać poprawnie!

    
odpowiedział BigSack 05.06.2012, 13:52
źródło
0

Mam pomysł, ponieważ seter netto pracuje w ubuntu 10.04, 11.04 itd.
Połącz & amp; dodaj połączenie mb bb w menedżerze sieci. Aby uzyskać pomoc dotyczącą Network Managera, spójrz na tutaj

    
odpowiedział Prasad V N. 08.04.2013, 12:23
źródło

Przeczytaj inne pytania na temat tagów