Jak zainstalować Bitcoin w Ubuntu?

51

Czy ktoś może przeprowadzić mnie przez proces instalacji Bitcoin na Ubuntu? Jestem nowicjuszem w Linuksie, a to naprawdę wszystko, co chcę zrobić z tym komputerem.

    
zadawane Miles 07.05.2011, 16:33
źródło

6 odpowiedzi

27

10.10

Launchpad ma osobiste archiwa paczek (PPA) dla bitcoin .

Możesz dodać ten PPA do źródeł oprogramowania twojego systemu: ppa:bitcoin/bitcoin Następnie możesz przeszukać centrum oprogramowania ubuntu dla bitcoin lub z poziomu sudo apt-get install bitcoin

Przy okazji: bitcoin jest dostępny tylko dla pojedynczych i klarownych, więc po dodaniu PPA zmień dystrybucję na indywidualną.

I zrzut ekranu, aby go ukończyć:

Piśmiennictwo:

Aby zmienić z "natty" na "maverick" dla PPA, możesz to zrobić z centrum oprogramowania Ubuntu:

Kliknij bitcoin PPA i wybierz edytuj. Następnie zmienia "Natty" na "Maverick":

Przeładuj źródła (poprosi o to) i powinieneś być w stanie zainstalować wersję bitcoin'a.

    
odpowiedział Rinzwind 07.05.2011, 16:54
źródło
52

Bitcoin ma teraz oficjalnie obsługiwany PPA z wersją kandydata na wersję demonstracyjną demona peer-to-peer i klienta.

Bitcoin ma projekt launchpacka , tj. taki sam status projektu jak Unity / Docky / Openshot itp. Opiekun - Matt Corallo - jest ważnym współtwórca oficjalnej witryny bitcoin.org .

To uaktualni wszystkie wersje od 10.04 i później.

Poniższe instrukcje uaktualnią twój system do najnowszej wersji klienta

sudo add-apt-repository ppa:bitcoin/bitcoin 
sudo apt-get update
sudo apt-get install bitcoin-qt

Potwierdzenie, że można z niego korzystać za pomocą forów Bitcoin .

    
odpowiedział fossfreedom 04.11.2011, 13:12
źródło
9

11.04

Bitcoin z Unity nie działa z powodu problemu z Compiz - jest to raport o błędzie

Ten problem został omówiony z kilkoma sugestiami na forach bitcoin

Podsumowując - jeśli nie chcesz zainstalować

  1. nowe wersje bitcoin albo przez ppa, albo z najnowszego źródła na stronie bitcoin, lub
  2. zaktualizuj biblioteki wxwidget,

powinieneś wylogować się z Unity i wybrać sesję "Ubuntu classic (bez efektów)" - czyli uruchamiając ubuntu bez żadnych efektów compiz.

    
odpowiedział fossfreedom 08.06.2011, 00:09
źródło
3

Przygotowałem ten skrypt, który wydawał się działać dla mnie zarówno na systemie Ubuntu 11.10 oniric, jak i na Ubuntu 13.10. Jednak jestem pewien, że jest pełen problemów i instalowania kodu, którego potencjalnie nie potrzebujesz. Jeśli ktokolwiek jest lepszym programistą basha, wejdź tam i wstaw kilka instrukcji if [ ...] , aby nie instalować wszystkich pakietów.

#!/bin/bash

# Word of caution, I am not an experienced shell programmer. All I can #
# guarantee is that this script has worked for me, and that it has     #
# done so on multiple Ubuntu machines (one 11.10 and one 13.10), so    #
# hopefully it will work for you too                                   #

# Install some packages as instructed on various web sites
sudo apt-get -y install qt4-qmake libqt4-dev build-essential libboost-dev libboost-system-dev libboost-filesystem-dev libboost-program-options-dev libboost-thread-dev libssl-dev
sudo apt-get -y install libtool autotools-dev autoconf
sudo apt-get -y install libdb4.8-dev # Generally this step fails
sudo apt-get -y install libdb4.8++-dev # Generally this step fails
sudo apt-get -y install libboost1.37-dev # Sometimes this step fail
sudo apt-get -y install libboost-all-dev # Sometimes this step fail
sudo apt-get -y install libminiupnpc-dev
sudo apt-get -y install libdb++-dev
sudo apt-get -y install libprotobuf-dev
sudo apt-get -y install libqrencode-dev

# Build berkley db4.8
# Technically, this should only be installed if the above              #
# libdb4.8XX-dev packages failed to install but nothing beats a little #
# overkill =)                                                          #
cd ~/Downloads
if [ ! -e db-4.8.30 ]
then
   wget http://download.oracle.com/berkeley-db/db-4.8.30.tar.gz
   tar zxvf db-4.8.30.tar.gz
   rm -f db-4.8.30.tar.gz
fi

cd db-4.8.30/build_unix
../dist/configure --prefix=/usr/local --enable-cxx # If this doesn't work, try removing or changing prefix
make
sudo make install
cd ~/Downloads
rm -fr db-4.8.30/ # If it still doesn't work, try commenting out this line

locate libdb4.8-dev # Comment this out as it may cause problems

if [ $? -ne "0" ]
then
   Failed to install db-4.8.30
   exit -1
fi

# Build bitcoin
cd ~/Downloads
if [ ! -e bitcoin ]
then
   git clone https://github.com/bitcoin/bitcoin ~/Downloads/bitcoin
fi

cd bitcoin

./autogen.sh
./configure # Non Ubuntu 13.xx versions
# ./configure --with-boost-libdir=/usr/lib/x86_64-linux-gnu # Ubuntu 13.xx version
make

cd ~/Downloads
rm -fr bitcoin
    
odpowiedział puk 04.12.2013, 23:36
źródło
2

Możesz spróbować użyć tego ppa: Bitcoin David Armstrong ppa launchpad

W oknie terminala (naciśnij Alt + F2 i wpisz gnome-terminal) i skopiuj + wklej następujące linie:

sudo add-apt-repository ppa:stretch/bitcoin
sudo apt-get update && sudo apt-get install bitcoin
    
odpowiedział tinuz 25.05.2011, 10:45
źródło
1

Oprócz odpowiedzi fossfreedom może być konieczne zainstalowanie add-apt-repository . Na przykład na serwerze Ubuntu (16.04 LTS)

Ten błąd:

sudo: add-apt-repository: command not found

W takim przypadku, do 16.04, potrzebujesz następujących poleceń:

sudo apt install software-properties-common
sudo add-apt-repository ppa:bitcoin/bitcoin 
sudo apt update
sudo apt install bitcoin-qt

Ale jeśli chodzi o serwer, najprawdopodobniej nie chcesz bitcoin-qt , ale bitcoind . Zmień ostatnią linię na:

sudo apt install bitcoind
    
odpowiedział berkes 09.01.2017, 12:12
źródło

Przeczytaj inne pytania na temat tagów