Nie można zainstalować odtwarzacza multimediów vlc w Ubuntu 16.04 LTS

9
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
vlc : Depends: vlc-nox (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Depends: libavcodec-ffmpeg56 (>= 7:2.4) but it is not going to be installed or
            libavcodec-ffmpeg-extra56 (>= 7:2.4) but it is not going to be installed
   Depends: libavutil-ffmpeg54 (>= 7:2.4) but it is not going to be installed
   Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
            libgles1
   Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
            libgles2
   Depends: libqt5x11extras5 (>= 5.1.0) but it is not going to be installed
   Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed
   Depends: libsdl1.2debian (>= 1.2.11) but it is not going to be installed
   Depends: libva-drm1 (>= 1.1.0) but it is not going to be installed
   Depends: libva-x11-1 (>= 1.0.3) but it is not going to be installed
   Depends: libva1 (>= 1.2.0) but it is not going to be installed
   Depends: libvlccore8 (>= 2.2.0) but it is not going to be installed
   Depends: libxcb-composite0 but it is not going to be installed
   Depends: libxcb-xv0 (>= 1.2) but it is not going to be installed
   Recommends: vlc-plugin-notify (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Recommends: vlc-plugin-samba (= 2.2.2+git20160830+r58831+56~ubuntu16.04.1) but it is not going to be installed
   Conflicts: vlc:i386 but 2.1.4-1 is to be installed
vlc:i386 : Depends: vlc-nox:i386 (= 2.1.4-1) but it is not going to be installed
        Depends: libaa1:i386 (>= 1.4p5) but it is not going to be installed
        Depends: libc6:i386 (>= 2.15) but it is not going to be installed
        Depends: libcaca0:i386 (>= 0.99.beta17-1) but it is not going to be installed
        Depends: libfreetype6:i386 (>= 2.2.1) but it is not going to be installed
        Depends: libfribidi0:i386 (>= 0.19.2) but it is not going to be installed
        Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
        Depends: libgl1-mesa-glx:i386 but it is not going to be installed or
                 libgl1:i386
        Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not going to be installed
        Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
        Depends: libsdl-image1.2:i386 (>= 1.2.10) but it is not going to be installed
        Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not going to be installed
        Depends: libstdc++6:i386 (>= 4.6) but it is not going to be installed
        Depends: libtar0:i386 but it is not going to be installed
        Depends: libva-x11-1:i386 (> 1.3.0~) but it is not going to be installed
        Depends: libva1:i386 (> 1.3.0~) but it is not going to be installed
        Depends: libvlccore7:i386 (>= 2.1.0) but it is not installable
        Depends: libx11-6:i386 but it is not going to be installed
        Depends: libxcb-composite0:i386 but it is not going to be installed
        Depends: libxcb-keysyms1:i386 (>= 0.3.9) but it is not going to be installed
        Depends: libxcb-randr0:i386 (>= 1.1) but it is not going to be installed
        Depends: libxcb-shm0:i386 but it is not going to be installed
        Depends: libxcb-xv0:i386 (>= 1.2) but it is not going to be installed
        Depends: libxcb1:i386 (>= 1.6) but it is not going to be installed
        Depends: libxext6:i386 but it is not going to be installed
        Depends: libxinerama1:i386 but it is not going to be installed
        Depends: libxpm4:i386 but it is not going to be installed
        Depends: zlib1g:i386 (>= 1:1.2.3.3) but it is not going to be installed
        Recommends: vlc-plugin-notify:i386 (= 2.1.4-1) but it is not going to be installed
        Recommends: vlc-plugin-pulse:i386 (= 2.1.4-1) but it is not installable
        Conflicts: vlc but 2.2.2+git20160830+r58831+56~ubuntu16.04.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Próbowałem już wszystkiego -f -f install

Ale nic nie działa. to nie wszystko, kiedy spróbuję sudo apt upgrade

Otrzymuję następujący błąd

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 vlc:i386 : Depends: vlc-nox:i386 (= 2.1.4-1) but it is not installed
            Depends: libaa1:i386 (>= 1.4p5) but it is not installed
            Depends: libc6:i386 (>= 2.15) but it is not installed
            Depends: libcaca0:i386 (>= 0.99.beta17-1) but it is not installed
            Depends: libfreetype6:i386 (>= 2.2.1) but it is not installed
            Depends: libfribidi0:i386 (>= 0.19.2) but it is not installed
            Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
            Depends: libgl1-mesa-glx:i386 but it is not installed or
                     libgl1:i386
            Depends: libqtcore4:i386 (>= 4:4.8.0) but it is not installed
            Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not installed
            Depends: libsdl-image1.2:i386 (>= 1.2.10) but it is not installed
            Depends: libsdl1.2debian:i386 (>= 1.2.11) but it is not installed
            Depends: libstdc++6:i386 (>= 4.6) but it is not installed
            Depends: libtar0:i386 but it is not installed
            Depends: libva-x11-1:i386 (> 1.3.0~) but it is not installed
            Depends: libva1:i386 (> 1.3.0~) but it is not installed
            Depends: libvlccore7:i386 (>= 2.1.0) but it is not installable
            Depends: libx11-6:i386 but it is not installed
            Depends: libxcb-composite0:i386 but it is not installed
            Depends: libxcb-keysyms1:i386 (>= 0.3.9) but it is not installed
            Depends: libxcb-randr0:i386 (>= 1.1) but it is not installed
            Depends: libxcb-shm0:i386 but it is not installed
            Depends: libxcb-xv0:i386 (>= 1.2) but it is not installed
            Depends: libxcb1:i386 (>= 1.6) but it is not installed
            Depends: libxext6:i386 but it is not installed
            Depends: libxinerama1:i386 but it is not installed
            Depends: libxpm4:i386 but it is not installed
            Depends: zlib1g:i386 (>= 1:1.2.3.3) but it is not installed
            Recommends: vlc-plugin-notify:i386 (= 2.1.4-1) but it is not installed
            Recommends: vlc-plugin-pulse:i386 (= 2.1.4-1) but it is not installable
E: Unmet dependencies. Try using -f.

Próbowałem nawet -f , ale nic się nie dzieje.

Proszę o pomoc

    
zadawane Akash Sarpal 31.08.2016, 10:01
źródło

7 odpowiedzi

20

Jedynym rozwiązaniem tego problemu jest dodanie stabilnego repozytorium w stylu Padoka Mesa ..

link

Następnie uruchom

sudo apt-get install vlc

To zadziała z pewnością, ponieważ powyższe repozytorium wymaga zarówno libli1-mesa, jak i libgles2-mesa dla vlc ..

    
odpowiedział Aadarsh 15.03.2017, 14:31
źródło
4

Spróbuj:

sudo apt-get remove vlc*
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install vlc
    
odpowiedział Black_FireFox 01.05.2017, 21:12
źródło
3

Możesz spróbować wykonać to samo, używając poniższego polecenia

sudo apt-get install aptitude
sudo aptitude install vlc
    
odpowiedział vembutech 31.08.2016, 13:09
źródło
1

Miałem dokładnie ten sam problem z bibliotekami (nie mogę zainstalować vlc z powodu problemów z bibliotekami libgles1-mesa i libgles2-mesa). Mógłbym rozwiązać problem za pomocą aptitude.

Nie można jednak zainstalować vlc od razu z powodu problemów z zależnościami bibliotek.

Najpierw musiałem zaktualizować libgles1-mesa z     $ sudo aptitude install libgles1-mesa

na pytanie do proponowanego rozwiązania (zachowanie niezainstalowanej biblioteki) odpowiedź: NIE

zaakceptuj alternatywną propozycję: przywróć libgl1-mesa-glx i libglapi-mesa do poprzednich wersji

to kontynuowałem z libgles2-mesa z:     $ sudo aptitude install libgles2-mesa

tym razem proponowane rozwiązanie nie miało problemu i zainstalowała bibliotekę

W tym momencie mógłbym zainstalować vlc z     $ sudo apt-get install vlc

i vlc był uruchomiony Hove to działa również dla ciebie!

    
odpowiedział Thierry B 15.09.2016, 20:44
źródło
0

prowadzisz z dwiema opcjami:

1) Możesz bezpośrednio zainstalować z "Centrum oprogramowania". Przejdź do oprogramowania ubuntu i wpisz w polu wyszukiwania "VLC". Tam możesz znaleźć gracza i możesz go zainstalować, klikając "Zainstaluj".

2) wypróbuj to polecenie w terminalu krok po kroku:

sudo apt-get update
sudo apt-get install vlc

sudo apt-get install vlc browser-plugin-vlc (embedded in Mozilla Firefox)
    
odpowiedział Avani badheka 31.08.2016, 10:16
źródło
0

Dodaj PPA do codziennych przedpremierowych wersji VLC i zainstaluj go:

sudo add-apt-repository ppa:videolan/master-daily
sudo apt update
sudo apt install vlc

Teraz otwórz VLC z Unity Dash (lub odpowiedniego programu uruchamiającego aplikacje).

    
odpowiedział Avani badheka 31.08.2016, 11:03
źródło
-1

To działało dla mnie

sudo apt-get update --fix-missing

sudo dpkg --configure -a

sudo apt-get install -f

, a następnie spróbuj zainstalować vlc za pomocą

sudo apt install vlc

    
odpowiedział Rahul Kumar 01.05.2017, 20:59
źródło

Przeczytaj inne pytania na temat tagów