Ustaw określoną rozdzielczość ekranu za pomocą xrandr

10

Więc zainstalowałem LUbuntu 11.04 na moim VirtualBox. Nie mogłem znaleźć rozdzielczości 1366x768, więc zainstalowałem Dodatki dla gości, ale jej tam nie było. Więc użyłem tego kodu, aby ustawić poprawną rozdzielczość:

gtf 1366 768 60
xrandr --newmode "1368x768_60.00"  85.86  1368 1440 1584 1800  768 769 772 795 $
xrandr --addmode VBOX0 1368x768_60.00
xrandr --output VBOX0 --mode 1368x768_60.00

Problem polega na tym, że nie mogę znaleźć sposobu na zapisanie tych informacji w celu ponownego uruchomienia komputera. Próbowałem na .xinitrc i nic się nie dzieje. Następnie próbowałem na .bashrc , ale to nie działa, muszę uruchomić konsolę przed wykonaniem tych poleceń.

    
zadawane dierre 16.01.2012, 17:13
źródło

5 odpowiedzi

8

Próbowałem zmienić domyślną rozdzielczość LXDE na Ubuntu (LXDE jest również używany w Lubuntu) i znalazłem rozwiązanie tego problemu. Mam również zainstalowany Lubuntu i sprawdziłem, czy ten plik faktycznie istnieje, co robi (tak samo wypróbowałem tę poprawkę i zadziałało).

Więc, poprawka ....

  1. Otwórz terminal, naciśnij Ctrl + Alt + T
  2. Domyślam się, że masz domyślną instalację Lubuntu, więc "Leafpad" będzie domyślnym edytorem, wpisz / skopiuj to do terminala i naciśnij enter ... (możesz zostać poproszony o podanie hasła)

    sudo leafpad /etc/xdg/lxsession/LXDE/autostart
    
  3. Teraz dodaj swoje komendy na dole pliku, dodając znak @ przed faktycznym poleceniem. Mój wyglądał tak po ...

    @xscreensaver -no-splash
    @lxpanel --profile LXDE
    @pcmanfm --desktop --profile LXDE
    @/usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1
    @xrandr --auto --output DVI-1 --primary --mode 1680x1050 --left-of DVI-0
    
odpowiedział captain_G 02.03.2012, 23:58
źródło
2

Osobiście umieszczam tego rodzaju polecenia, aby były uruchamiane przy logowaniu, w skrypcie w ~/bin , nazwij go set_resolution

Następnie uruchom gnome-session-properties i dodaj polecenie do uruchomienia przy logowaniu (użyj ~ / bin / set_resolution).

    
odpowiedział Panther 17.01.2012, 06:00
źródło
1

Oto kolejna linia dodana do mojego pliku /etc/xdg/lxsession/LXDE/autostart , aby działała:

@xrandr --output LVDS --off

wskazówka od: link

Aktualizacja: powyższe było w porządku na chwilę, dopóki nie uruchomiłem narzędzia konfiguracyjnego GUI lxrandr , co wydaje się głupio nieświadome konfiguracji podwójnego monitora. Więc dokonałem tej zmiany:

$ cat $HOME/.config/autostart/lxrandr-autostart.desktop

[Desktop Entry]
Type=Application
Name=LXRandR autostart
Comment=Start xrandr with settings done in LXRandR --then manually tweaked
Exec=xrandr --output DVI-0 --mode 1920x1200 --rate 60.0 --output LVDS --off --output VGA-0 --primary --mode 1920x1200 --left-of DVI-0
OnlyShowIn=LXDE

Zauważ, że używam Ubuntu 12.04 z LXDE. Można mieć nadzieję, że czysta instalacja 12/06 w Lubuntu będzie zawierała sprytniejsze lxrandr binarne ...

    
odpowiedział MarkHu 26.09.2012, 00:06
źródło
1

Ta strona pomogła mi: link

W końcu wprowadziłem zmiany w ~ / .xprofile

    
odpowiedział rtconner 12.10.2013, 11:16
źródło
0

Jeśli ktokolwiek wciąż zmaga się z tym, spróbowałem wszystkiego, co mogłem znaleźć bez powodzenia (umieściłem wiersz poleceń w tak wielu plikach, które straciłem). W końcu znalazłem łatwe rozwiązanie dzięki próbom i błędom i wypróbowałem je najpierw przed wszystkimi innymi.

Otwórz terminal i przetestuj komendę xrandr (jak zostały opublikowane przez innych). Używam Lubuntu na starym systemie, aby dać mu trochę więcej życia i mam stary monitor podłączony do niego, więc moja linia cmd do zmiany rozdzielczości

xrandr --auto --output VGA1 - podstawowa - tryb 1158x864

nie dodał żadnych innych rzeczy.

Następnie uruchomiono preferencje- > Aplikacje domyślne dla LXSession

Wybrane menu "autostart", a następnie umieścić dokładny kod linii poleceń w białym polu tekstowym i kliknąć "dodaj".

Ponownie uruchomiony i sukces !!!

    
odpowiedział Russell Hepworth 17.09.2014, 22:56
źródło

Przeczytaj inne pytania na temat tagów