Wyłącz autostart Dockera podczas startu?

16

Próbowałem eksperymentować z docker , Ubuntu 14.04, 64-bit. Udało mi się uruchomić obraz i dałem mu ścieżkę na jednym z dysków wymiennych, /media/Drive1 .

Teraz, gdy ponownie się uruchomię, widzę, że jest tam /media/Drive1 z tylko katalogiem docker wewnątrz, a rzeczywisty dysk, który powinien być Drive1 , kończy się na /media/Drive11 i dzieje się to przy każdym ponownym uruchomieniu - nawet po odmontowaniu tych napędów i zrobieniu sudo rm -rfv /media/Drive1 przed ponownym uruchomieniem!

Więc coś prawdopodobnie tworzy /media/Drive1 , zanim zostanie w pełni zamontowany, i domyślam się, że coś jest docker , ponieważ po uruchomieniu mam:

$ ps axf | grep docker
 2085 ?        Ssl    0:00 /usr/bin/docker -d

Jak więc wyłączyć autostart docker , aby nie przeszkadzał w podłączaniu zewnętrznych dysków USB podczas rozruchu?

    
zadawane sdbbs 02.05.2016, 13:27
źródło

2 odpowiedzi

5

Ok, myślę, że udało mi się sprawić, żeby działało, po Jak włączyć lub wyłączyć usługi? :

sudo bash -c 'echo manual | sudo tee /etc/init/docker.override'

Mam nadzieję, że to było ...

    
odpowiedział sdbbs 02.05.2016, 13:37
źródło
21

W systemach od wersji Ubuntu 16.04+ (gdzie OS używa systemd ), zgodnie z doc , autostart on boot może zostać wyłączony przez:

$ sudo systemctl disable docker.service
$ sudo systemctl disable docker.socket

Pamiętaj, że jeśli nie wyłączysz gniazda, a także usługi, usługa zostanie uruchomiona tak czy inaczej, ponieważ gniazdo zależy od tego.

    
odpowiedział TitanFighter 05.02.2017, 22:00
źródło

Przeczytaj inne pytania na temat tagów