CMake nie może znaleźć PythonLibs

10

Próbuję budować inria Graphite na moim ubuntu, który działa w symulatorze VirtualBox, postępuję zgodnie z instrukcjami i instaluję pakiety python-dev , ale kiedy uruchomię cmake, wciąż pojawia się błąd:

CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108          (message):
Could NOT find PythonLibs (missing: PYTHON_LIBRARIES PYTHON_INCLUDE_DIRS)
(Required is at least version "3.2")
Call Stack (most recent call first):
 /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:315     (_FPHSA_FAILURE_MESSAGE)
 /usr/share/cmake-2.8/Modules/FindPythonLibs.cmake:208 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
 src/packages/OGF/gel_python3/CMakeLists.txt:11 (FIND_PACKAGE)

Sprawdziłem /usr/lib/ i znalazłem

tintin@tintin-VirtualBox:/usr/lib$ find . -name "libpython*"
./x86_64-linux-gnu/libpython3.4m.so.1.0
./x86_64-linux-gnu/libpython2.7.so.1.0
./x86_64-linux-gnu/libpython3.4m.a
./x86_64-linux-gnu/libpython2.7.a
./x86_64-linux-gnu/libpython3.4m.so
./x86_64-linux-gnu/libpython2.7.so
./x86_64-linux-gnu/libpython2.7.so.1
./x86_64-linux-gnu/libpython3.4m.so.1

więc dlaczego cmake nie może znaleźć PythonLibs, czy jak mam sobie z tym poradzić?

    
zadawane tintin 08.06.2014, 04:30
źródło

4 odpowiedzi

17

Instalacja python-dev faktycznie naprawiła to dla mnie:

sudo apt-get install python-dev

Masz podpowiedź tutaj: link

    
odpowiedział helgar 26.06.2015, 22:46
źródło
10

Problem polega na tym, że Ubuntu 14.04 domyślnie instaluje Python 3.4, a wersja CMake z Ubuntu (2.8) wyszukuje tylko Python 3.3. Rozwiązaniem jest dodanie set(Python_ADDITIONAL_VERSIONS 3.4) przed instrukcją find_package . Zauważ, że zgłosiłem błąd dotyczący tego problemu.

Od CMake 3.0, CMake wyszukuje do wersji Python 3.4 , więc ręczne zainstalowanie tej wersji również powinno rozwiązać problem .

    
odpowiedział Job 24.08.2014, 17:26
źródło
2

Dla mnie problemem była zła pamięć podręczna

rm CMakeCache.txt

Usunął pamięć podręczną ze starą wersją 2.7 i pozwolił jej znaleźć 3.2 w moim przypadku.

Zastosowany cmake to

find_package(PythonInterp 3.2 REQUIRED)
find_package(PythonLibs 3.2 REQUIRED)
message(STATUS "PYTHON_LIBRARIES = ${PYTHON_LIBRARIES}")
message(STATUS "PYTHON_EXECUTABLE = ${PYTHON_EXECUTABLE}")
message(STATUS "PYTHON_INCLUDE_DIRS = ${PYTHON_INCLUDE_DIRS}")
...
include_directories(${PYTHON_INCLUDE_DIRS})
    
odpowiedział Dirk Bester 10.01.2015, 05:52
źródło
1

Ostatnio miałem podobny problem z 64-bitowym Ubuntu 14.04; podobno CMake domyślnie nie szuka folderów instalacyjnych zależnych od architektury:

CMake constructs a set of possible installation prefixes for the package. Under
each prefix several directories are searched for a configuration file. The tables
below show the directories searched.

[...]

  <prefix>/(lib/<arch>|lib|share)/cmake/<name>*/          (U)
  <prefix>/(lib/<arch>|lib|share)/<name>*/                (U)
  <prefix>/(lib/<arch>|lib|share)/<name>*/(cmake|CMake)/  (U)

[...]

In all cases the <name> is treated as case-insensitive and corresponds to any of
the names specified (<package> or names given by NAMES). Paths with lib/<arch>
are enabled if CMAKE_LIBRARY_ARCHITECTURE is set.

(z CMake 2.8.12 dokumentacja online find_package command )

Rozwiązanie polega na ustawieniu tego CMAKE_LIBRARY_ARCHITECTURE w głównym pliku projektu CMakeLists.txt (w twoim przypadku, który byłby edycją src / packages / OGF / gel_python3 / CMakeLists.txt) przed wywołaniem find_package dla PythonLibs; na przykład:

cmake_minimum_required(VERSION 2.8)
project(project_name)

# Check the architecture and set CMAKE_LIBRARY_ARCHITECTURE accordingly
if(UNIX)
  if(CMAKE_SIZEOF_VOID_P EQUAL 8)
    set(CMAKE_LIBRARY_ARCHITECTURE "x86_64-linux-gnu")
  endif()
endif()

find_package(PythonInterp 3.2 REQUIRED)
find_package(PythonLibs 3.2 REQUIRED)

# Rest of your file

To działało w moim przypadku.

    
odpowiedział Bertrand Moreau 17.07.2014, 10:14
źródło

Przeczytaj inne pytania na temat tagów