Pliki w /etc/network/interfaces.d ignorowane, ale nie / etc / network / interfejsy się

17

Dla Ubuntu 16.04 LTS (GNU / Linux 3.10.96-113 armv7l)

Gdy mam następujące, moja statyczna konfiguracja jest ignorowana:

/ etc / network / interfaces

source-directory /etc/network/interfaces.d

/etc/network/interfaces.d/eth0

auto eth0
iface eth0 inet static
        address 192.168.40.112
        netmask 255.255.255.0
        gateway 192.168.40.1
        dns-nameservers 8.8.8.8

Jednakże z następującymi:

/ etc / network / interfaces

auto eth0
iface eth0 inet static
        address 192.168.40.112
        netmask 255.255.255.0
        gateway 192.168.40.1
        dns-nameservers 8.8.8.8

source-directory /etc/network/interfaces.d

konfiguracja statyczna jest ustawiana podczas startu (niezależnie od tego, co mam w interfejsach.d /).

Jeśli jest to istotne, używam reguły udev, aby zmienić nazwę interfejsu eth0 (kiedyś było to "enx001e063110c0" ...)

    
zadawane Luis de Arquer 25.11.2016, 21:14
źródło

3 odpowiedzi

22

Myślę, że to znalazłem. Z instrukcji obsługi wynika, że problem dotyczy słowa kluczowego source-directory . Wygląda na to, że od 16.04 nie jest już obsługiwany.

Tak więc zastępuję

source-directory /etc/network/interfaces.d

z

source /etc/network/interfaces.d/*

wydaje się naprawić problem.

    
odpowiedział Luis de Arquer 27.11.2016, 16:02
źródło
3

Miałem mniej więcej ten sam problem. Okazuje się, że source-directory jest obsługiwany w moim systemie, ale obejmuje tylko pliki, których nazwy plików składają się z liter, cyfr, kresek i podkreśleń.

Dlatego mój eth0.conf nie został odczytany, ponieważ zawierał kropkę.

    
odpowiedział Sjoerd 21.08.2017, 19:11
źródło
2

Twoje jądro 3.10 jest za stare na systemd IFF przy użyciu systemd-v230 lub nowszego .

Zgodnie z wymaganiami jądra systemd w github na ( github.com - systemd README ) możesz need version > = 3.12, jeśli używasz systemd-v230 lub nowszego:

REQUIREMENTS:
        Linux kernel >= 3.12
        Linux kernel >= 4.2 for unified cgroup hierarchy support

Wiersze 37, 38 i 39 są wydrukowane powyżej.

Pracujesz w architekturze ARM, o której szczerze mówiąc niewiele wiem. Wyszukiwarka Google mówi mi, że twój armvl7 jest używany przez Raspberry Pi i jest 32-bitowym jądrem.

Aktualizowanie jądra do współczesności

Jeśli chcesz najnowszą ( 21 października 2016 r. ) ochronę bezpieczeństwa "Dirty COW" ( Co to jest błąd" Dirty COW "i jak mogę zabezpieczyć mój system przed nim? ) oraz wiele innych poprawek zabezpieczeń, poprawek i ulepszeń systemu ( po wersji 2013 ) powinieneś znaleźć się na jądrze 4.4.0-47.

Niestety nie wiem jak to zrobić dla RaspberryPi. Połączyłem to pytanie z osobami, które używają RaspberryPi i poprosiłem ich o krytyczną odpowiedź.

    
odpowiedział WinEunuuchs2Unix 26.11.2016, 01:32
źródło

Przeczytaj inne pytania na temat tagów