Nie można użyć skrótów klawiszowych IntelliJ IDEA w systemie Ubuntu

118

Jestem bardzo nowym użytkownikiem Ubuntu i mam problem, którego nie wiem, jak go naprawić. Próbowałem nawet szukać w Internecie odpowiedzi, ale może nie znam odpowiednich terminów wyszukiwania.

Pracuję z IntelliJ IDEA , aplikacją do programowania. Jestem bardzo przyzwyczajony do skrótów klawiszowych, ale kiedy przestawiłem się z Windows XP na Ubuntu 13.10, niektóre skróty już nie działają. Na przykład takie jak;

  • Ctrl + Alt + (strzałka w lewo)
  • Alt + F8

Czy jest jakiś powód, dlaczego? i czy są jakieś poprawki? A może po prostu coś, co poprowadzi mnie do wyszukiwania

Dziękuję bardzo z góry.

    
zadawane Rodrigo Sasaki 28.01.2014, 13:01
źródło

10 odpowiedzi

190

Podczas czytania nauczyłem się, że Intellij IDEA to IDE zorientowane na klawiaturę. Co to znaczy, że użycie może z nim pracować bez dotykania myszy. Również zarządzam ustawieniem mapy klawiszy.

Dla Ubuntu

Zobacz jak zmienić skróty klawiszowe?

Oto lista poprawek, które musisz wykonać przy domyślnych powiązaniach klawiszy systemowych, aby nie zakłócały działania IntelliJ IDEA (wymienione w nawiasach).

  
  • Wyłącz akcję okna Cień, przypisaną do Ctrl + Alt + S (Okno dialogowe ustawień)
  •   
  • Zmień lub wyłącz działanie blokady ekranu, przypisane do Ctrl + Alt + L (Kod Reformat)
  •   
  • Zmiana lub dezaktywacja akcji terminalu uruchamiania, przypisanej do Ctrl + Alt + T (Surround with)
  •   
  • Zmień lub wyłącz działanie Przełącz na obszar roboczy, przypisane do Ctrl + Alt + Klawisze strzałek (Nawigacja)
  •   
  • Wyłącz działanie okna ruchu, przypisane do Alt + F7 (Znajdź zastosowania)
  •   
  • Zmień lub wyłącz działanie okna zmiany rozmiaru przypisane do Alt + F8 (Ocena wyrażenia)
  •   

Mam nadzieję, że to pomoże!

Uwaga: Zawsze możesz przywrócić skróty Ubuntu do stanu domyślnego. Wystarczy zapoznać się z Jak przywrócić domyślne skróty klawiaturowe? , na wypadek utraty połączenia .

Źródło: - Intelli IDEA Keymap

    
odpowiedział AzkerM 28.01.2014, 13:39
źródło
28

Wpadłem też na ten problem, moje rozwiązanie było jednak inne.

Nie trzeba włamywać się ani zmieniać mapy całego systemu

IntelliJ ma różne mapy klawiszy, które można zmieniać w zależności od systemu operacyjnego.

Możesz zmienić swoją mapę klawiszy IntelliJ w ustawieniach.

Po prostu przejdź do Settings -> Keymap i wybierz żądaną mapę klawiszy z rozwijanego menu. W moim przypadku wybrałem "Default for GNOME", ponieważ używam Ubuntu Gnome 16.04.

    
odpowiedział Francisco C. 25.06.2016, 07:18
źródło
15

Dla ubuntu 18.04 LTS ctrl + alt + lewy (konflikt skrótu Intellij idea)

  • zainstaluj edytor Dconf w oprogramowaniu ubuntu
  • uruchom edytor Dconf, przejdź do / org / gnome / desktop / wm / keybindings / switch-to-workspace-left

  • Kliknij dwukrotnie, jak poniżej

  • używaj wartości domyślnej (kliknij Wyłącz) - > Wartość niestandardowa (taka jak ja lub inna)

  • możesz go teraz użyć w intellijskim pomyśle

    
odpowiedział think 06.05.2018, 11:42
źródło
5

Stworzyłem ten skrypt, który wyłącza wszystkie sprzeczności między Ubuntu (testowane z 15.10) a IntelliJ (i prawdopodobnie więcej produktów Jetbrains). Wyłącza je w Ubuntu.

Tworzy również plik kopii zapasowej, dzięki czemu można przywrócić poprzednie ustawienia.

Aby nie wyłączać niektórych skrótów, skomentuj je w tablicy KEYS .

#!/bin/bash
set -euo pipefail

# Disables Ubuntu shortcuts that clash with IntelliJ Idea (and probably other
# Jetbrain products).
#
# Creates a backup file to restore the previous settings. To not have some
# shortcuts disabled, comment them out in the 'KEYS' array.
#
# Tested on : Ubuntu 15.10
# Author    : Jonas Gröger

readonly BACKUP_FILE="undo-fix-shortcuts-$(date +%s%N).sh"
readonly KEYS=(
    "/org/gnome/desktop/wm/keybindings/toggle-shaded"
    "/org/gnome/settings-daemon/plugins/media-keys/screensaver"
    "/org/gnome/settings-daemon/plugins/media-keys/terminal"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-down"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-up"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-left"
    "/org/gnome/desktop/wm/keybindings/switch-to-workspace-right"
    "/org/gnome/desktop/wm/keybindings/begin-move"
    "/org/gnome/desktop/wm/keybindings/begin-resize"
    # To disable resetting a value, just comment out the line
)
readonly DISABLED_VALUE="['disabled']"

main() {
    # Make backup
    printf "#!/bin/bash\n" >>  "$BACKUP_FILE"
    for key in "${KEYS[@]}"; do
        local value
        value=$(dconf read "$key")
        printf "dconf write \"%s\" \"%s\"\n" "$key" "$value" >> "$BACKUP_FILE"
    done

    # Disable all Ubuntu shortcuts
    for key in "${KEYS[@]}"; do
        dconf write "$key" "$DISABLED_VALUE"
    done
}
main

Możesz go pobrać stąd:

wget -O fix-shortcuts.sh https://gist.githubusercontent.com/JonasGroeger/94cfa1071fa12572f465/raw/fix-shortcuts.sh
    
odpowiedział Jonas Gröger 16.12.2015, 22:40
źródło
3

Zobacz tutaj , aby dowiedzieć się, jak programowo wyłączyć skróty do Ubuntu i tylko wtedy, gdy są aktywne okna niektórych aplikacji.

W szczególności użyj tych wartości (zakładając, że korzystasz z zestawu JetBrains Toolbox ze standardową ścieżką instalacji, w razie potrzeby dostosuj się):

apppattern = "JetBrains"
backupfile = "~/.local/share/JetBrains/keymap_backup"

Podczas działania skryptu, skróty Ubuntu zawsze będą działały, z wyjątkiem sytuacji, gdy IDEA i in. mieć ostrość.

Mam kolekcję skrótów specyficznych dla JetBrains tutaj ; wejście jest docenione.

    
odpowiedział Raphael 22.12.2016, 14:32
źródło
2

Wystarczy trochę rozszerzyć doskonałą odpowiedź AzkerM:

  
  • Wyłącz działanie okna ruchu, przypisane do Alt + F7 (Znajdź zastosowania)      
        
    • z Ustawień - > Klawiatura - > Skróty - > Windows - > Przenieś okno
    •     
  •   
  • Zmień lub wyłącz akcję okna zmiany rozmiaru przypisaną do Alt + F8 (Ocena wyrażenia)      
        
    • z Ustawień - > Klawiatura - > Skróty - > Windows - > Zmień rozmiar okna
    •     
  •   
    
odpowiedział WillC 24.02.2016, 12:15
źródło
1

Używam Ubuntu 16.04 i to, co się dzieje, kiedy użyłem tych naciśnięć klawiszy (ctrl-alt-left / right), okno zmieniało rozmiar i umieszczało się po prawej lub lewej stronie ekranu. Próbowałem wyłączyć te wiązania klawiszy w: Ustawienia / Klawiatura / Nawigacja, mimo że nie mam włączonych obszarów roboczych. To nadal nie przeszkodziło w zachowaniu, które widziałem.

Na szczęście otworzyłem Compiz i natknąłem się na wtyczkę Window Management / Grid, która mapowała te klawisze, aby umieścić okna w pozycji siatki. Wyłączyłem tę wtyczkę, a teraz skróty klawiszowe IntelliJ działają dobrze z ctrl-alt-left / right.

    
odpowiedział Jason White 14.06.2016, 00:08
źródło
1

Kilka szybkich obejść:
Jeśli masz klawisz " Windows " na klawiaturze, możesz po prostu dodać go do całej kombinacji skrótów - to powinno działać. Na przykład:

  • Ctrl + Win + Alt + T (Surround z)
  • Wygraj + Alt + F8 (Oceń wyrażenie )
odpowiedział guzoff 28.11.2017, 21:53
źródło
0

W Ubuntu 16.04 przejdź do ustawień > Klawiatura i znajdź konkretną kombinację w konflikcie z żądanym kliknięciem i zaktualizuj kombinację do nowej.

    
odpowiedział Cengkuru Michael 29.10.2017, 10:22
źródło
0

Używam Xneura do zmiany błędnego tekstu na inny język. Mój system langauge jest śledzony przez Ctrl + Shift , co blokuje skróty klawiaturowe Intellij , takie jak Ctrl + Shift + F (globalne wyszukiwanie) i Ctrl + Shift + C (komentarz). Więc przesunięcie w lewo jest ignorowane.

  • Jednym z rozwiązań jest zmiana języka za pomocą Ctrl_L + Shift_L i użycie Ctrl_R + Shift_R dla Intellij . Ale jest to pewien dyskomfort.

  • Drugim rozwiązaniem jest użycie Xneur ( sudo ap-get install xneur ) do wpisz ponownie błędny tekst w innym języku. Możesz wyłączyć dowolne przełączanie w systemie i przypisać je do klawiszy skrótów Xneur (ten sam Ctrl+Shift ). Xneur można dodać do autostartowanych aplikacji.

odpowiedział Zon 04.09.2018, 07:28
źródło

Przeczytaj inne pytania na temat tagów