wyświetla problem z jasnością w Ubuntu 13.04

10

Mam Dell Inspiron 5520 z procesorami Intel Core i7 i AMD Graphics. Kiedyś działało dobrze z Ubuntu 12.04 i Ubuntu 12.10. Teraz próbowałem zainstalować Ubuntu 13.04, ale nie mogę zmienić jasności wyświetlacza: klawisze FN go nie zmieniają, wskaźnik pokazuje, że zawsze jest prawie pełny, ale nie zmieni się, nie zwiększy się ani nie zmniejszy. Ten sam problem dotyczy zarówno wersji Ubuntu dla x86, jak i amd64.

W czym problem?

    
zadawane mbkfa93 30.04.2013, 06:19
źródło

10 odpowiedzi

10

Miałem ten sam problem i rozwiązałem go po tym wierszu:

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

w pliku / etc / default / grub, a po:

# update-grub && reboot

Mam jednego Dell Vostro 3560 z jądrem Ubuntu 13.04 x86_64 3.8.0-19-generic

Używam ogólnego sterownika wideo X.Org (opensource, przetestowany)

    
odpowiedział Tiago Cruz 07.05.2013, 14:12
źródło
7

Poniższe problemy rozwiązały problem w moim laptopie Acer.

Otwórz etc/default/grub z głównym edytorem tekstu

sudo -H gedit /etc/default/grub

Zmień

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

do

GRUB_CMDLINE_LINUX="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Po tym uruchom% sudo update-grub i zrestartuj system.

    
odpowiedział Snigdha Batra 12.12.2013, 11:45
źródło
5

Znajdź wideo / kartę graficzną w Ubuntu i Linux Mint

Uruchom polecenie w terminalu, aby wiedzieć, jaka karta wideo jest używana do podświetlenia / jasności:

ls /sys/class/backlight/

znajdź sterownik graficzny w Ubuntu

Jak widzisz, wyjście dla mnie to dell_backlight i intel_backlight. Wskaźnik, że używana karta graficzna to Intel. Innym sposobem znalezienia karty graficznej będzie przejście do Ustawień systemowych > Szczegóły-> Grafika. Możesz zobaczyć używaną kartę graficzną.

Jeśli twoją kartą graficzną jest Intel, możesz przystąpić do poniższej poprawki. Napraw problem z kontrolą jasności z kartą Intel w Ubuntu i Linux Mint:

Otwórz terminal i utwórz następujący plik konfiguracyjny, jeśli nie istnieje:

sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf

Teraz musimy edytować ten plik. Możesz użyć dowolnego edytora, czy to terminalowego czy graficznego.

sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf

Dodaj następujące wiersze do tego pliku:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

Zapisz. Wyloguj się i zaloguj ponownie. Sterowanie jasnością powinno teraz działać poprzez klawisze funkcyjne:

Napraw kontrolę jasności nie działa w Ubuntu 13.10

    
odpowiedział Manikandaprabu.N 03.08.2014, 05:55
źródło
4

Mam taki sam problem w Lenovo G580,

ale rozwiązałem to przez edycję grub,

/etc/default/grub file

i wstaw tę linię na końcu

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

i po tej aktualizacji grub,

 update-grub

i gotowe

    
odpowiedział MROHIT 22.09.2013, 05:08
źródło
1

Mam ten sam problem na Asus Zenbook UX32VD, ale rozwiązałem go przez dodanie znaku komentarza # przed następującym wierszem w pliku / etc / default / grub:

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"
    
odpowiedział blaskino 05.06.2013, 12:12
źródło
1

GRUB_CMDLINE_LINUX_DEFAULT="splash quiet acpi_osi="! Windows 2012 ""

to działa najlepiej w przypadku większości laptopów, które mają ten problem, w tym mojego ASUS K55VM. Jest to z pierwotnego wiki systemu Ubuntu Zenbook link

    
odpowiedział Arup Roy Chowdhury 10.09.2013, 10:21
źródło
1

Mam laptopa Asusa i to właśnie zrobiłem, aby naprawić problem z jasnością. Zamiast używać klawiszy fn + jasność góra / dół, spróbuj użyć klawiszy fn + alt + jasność góra / dół. Mam nadzieję, że to pomoże.

    
odpowiedział Brett Trisko 16.07.2014, 11:51
źródło
1

Żadna z opcji tutaj nie działała dla mnie z Asus Zenbook UX303. Zakończyłem tworzenie niestandardowych skrótów i korzystania z pakietu xbacklight .

sudo apt-get install xbacklight
xbacklight -set 50 # set to 50%
xbacklight -inc 5 # increase by 5%pt
xbacklight -dec 5 # decrease by 5%pt

Następnie możesz utworzyć skróty dla wariantu -inc i -dec . Brakuje tylko ekranu w prawym górnym rogu, mówiącego, jak jasny jest obecnie wyświetlacz.

    
odpowiedział Keelan 27.05.2015, 22:47
źródło
0

Zakładam, że zainstalowałeś już sterownik amd (dash - > źródła oprogramowania - > ostatnia karta)

ubuntuforums.org/showthread.php?t=2139397
spójrz na parametry rozruchu jądra
plik do edycji to /etc/default/grub
po edycji uruchom sudo update-grub i zrestartuj

    
odpowiedział GM-Script-Writer-62850 30.04.2013, 06:25
źródło
0

Ten sam problem na Acer Aspire E1-531. Rozwiązano:

Otwórz etc/default/grub z głównym edytorem tekstu:

sudo -H gedit /etc/default/grub

Dodaj:

GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

na końcu pliku.

Po tym uruchom% sudo update-grub i zrestartuj system.

PS. Możesz także znaleźć GRUB_CMDLINE_LINUX="" na linii 12. Po prostu dodaj acpi_backlight=vendor .

Uruchom update-grub i zrestartuj system.

    
odpowiedział Gjorgji Pop-Gjorgjiev 07.09.2014, 21:06
źródło

Przeczytaj inne pytania na temat tagów