Jak wyłączyć sesję gościa?

180

Jak wyłączyć sesję gościa w systemie Ubuntu 11.10 lub nowszym? Nie chcę, aby ludzie mogli używać mojego komputera bez logowania się przy użyciu hasła!

    
zadawane Jeremy Bicha 22.09.2011, 17:45
źródło

12 odpowiedzi

116

Zaktualizowano: 2016-sierpień

Dla Ubuntu 16.04 LTS (15.10 lub nowszy)

Dopasowano: LightDM Ubuntu Wiki - Konfiguracja

  • Dostarczone przez system pliki konfiguracyjne w /usr/share/lightdm/ nieprzeznaczone do edycji przez użytkownika. Zamiast tego użytkownicy powinni używać: /etc/lightdm/
  • Nowsze wersje LightDM (Ubuntu 15.10 lub nowsze) używają [Seat:*] zamiast [SeatDefaults]

Po prostu uruchom (raz) na terminalu:

sudo sh -c 'printf "[Seat:*]\nallow-guest=false\n" >/etc/lightdm/lightdm.conf.d/50-no-guest.conf'

Aby cofnąć (przywrócić opcję Guest), usuń utworzony plik :

sudo rm /etc/lightdm/lightdm.conf.d/50-no-guest.conf

Dla Ubuntu 14.04 LTS (do 15.04)

Dopasowano: Fora Ubuntu - lokalizacja plików konfiguracyjnych lightdm w 14.04

Po prostu uruchom (raz) na terminalu:

sudo sh -c 'printf "[SeatDefaults]\nallow-guest=false\n" >/usr/share/lightdm/lightdm.conf.d/50-no-guest.conf'

Podczas następnego logowania nie będziesz już mieć "gościa" jako opcji logowania.

Aby cofnąć (przywrócić opcję Guest), usuń utworzony plik :

sudo rm /usr/share/lightdm/lightdm.conf.d/50-no-guest.conf

Dla Ubuntu 12.04 LTS (do 13.10)

Najprostsza metoda.

Po prostu uruchom (raz) na terminalu:

sudo /usr/lib/lightdm/lightdm-set-defaults -l false

Podczas następnego logowania nie będziesz już mieć "gościa" jako opcji logowania.

  • To po prostu dołącza allow-guest=false do /etc/lightdm/lightdm.conf .

  • Powinien działać od 11.10 (ponieważ używają LightDM ).

Aby cofnąć (przywrócić opcję Guest):

sudo /usr/lib/lightdm/lightdm-set-defaults -l true
    
odpowiedział david6 28.07.2012, 01:38
źródło
113
  

Używaj tej metody tylko, jeśli używasz Ubuntu Desktop. Jeśli używasz innego smaku, takiego jak Xubuntu lub Lubuntu, skorzystaj z tej odpowiedzi zamiast tego.

Jeśli używasz domyślnego LightDM, edytuj /etc/lightdm/lightdm.conf tak, aby wyglądał następująco:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Jeśli używasz GDM (który był domyślny w poprzednich wydaniach Ubuntu), odinstaluj gdm-guest-session .

Dla Ubuntu 13.10 do 14.10 plik został przeniesiony do /etc/lightdm/lightdm.conf.d/50-unity-greeter.conf

Dla Ubuntu 14.10 lub nowszego plik został przeniesiony /usr/share/lightdm/lightdm.conf.d/50-unity-greeter.conf

    
odpowiedział Jeremy Bicha 22.09.2011, 17:48
źródło
23

Wpisz to w terminalu

gksu gedit /etc/lightdm/lightdm.conf

Zobaczysz:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu

Dodaj allow-guest=false do końca, aby Twój końcowy wynik wyglądał następująco:

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
allow-guest=false

Zapisz dokument i zamknij edytor tekstu.

Wracając do terminalu, zrestartuj menedżer wyświetlania. (To zakończy graficzną sesję logowania, natychmiast opuszczając wszystkie uruchomione w niej programy, więc upewnij się, że twoja praca - tak jak wszystkie otwarte dokumenty - jest zapisywana jako pierwsza!)

sudo restart lightdm

Po zakończeniu graficznej sesji logowania wracasz do ekranu logowania, gdzie zauważysz, że liczba gości jest wyłączona.

To wszystko - konto gościa nie jest już dostępne.

    
odpowiedział sarveshlad 25.10.2011, 03:08
źródło
16

Możesz to zrobić za pomocą Ubuntu Tweak .

Aby zainstalować, użyj następujących poleceń:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Po instalacji przejdź do Poprawek Ustawienia logowania i wyłącz "Konto gościa".

    
odpowiedział Eliran Malka 21.10.2012, 19:54
źródło
11

Po prostu uruchom

gksudo gedit /etc/lightdm/lightdm.conf

Dodaj następujący wiersz

allow-guest=false

Następnie (to natychmiast wyloguje Cię, zamykając programy uruchomione w twojej sesji graficznej, więc najpierw zapisz swoją pracę):

sudo restart lightdm
    
odpowiedział LnxSlck 27.07.2012, 18:42
źródło
3

Dla Ubuntu 13.10 dodaj

allow-guest=false

do pliku /etc/lightdm/lightdm.conf.d/10-ubuntu.conf .

    
odpowiedział uahummer 20.10.2013, 15:27
źródło
3

13.04 i nowsze

  1. Wykonaj to polecenie w terminalu

    sudo /usr/lib/lightdm/lightdm-set-defaults -l false
    
  2. Uruchom ponownie komputer lub uruchom ponownie lightdm za pomocą następującego polecenia
    (to spowoduje natychmiastowe wylogowanie, zapisanie danych)

    sudo restart lightdm
    

Najwyraźniej działa w 13.10 (nie mogę przetestować siebie, ale jest komentarz tutaj ).

Używam 13.04 i wszystko to dodaje allow-guest=false do /etc/lightdm/lightdm.conf , ale może być inaczej w 13.10.

Oryginalnie przez david6 stąd: link

    
odpowiedział kiri 21.10.2013, 09:33
źródło
3

Jak wyłączyć tę opcję w przyszłości

Właśnie napotkałem ten sam problem w mojej nowej instalacji zaufanej / 14.04. Ku mojemu zaskoczeniu nie mogłem znaleźć folderu lightdm.conf.d wewnątrz /etc/lightdm/ tylko users.conf .

Dochodzenie

$ find / -iname *lightdm* 2>/dev/null | grep -v /mnt | grep -v /media | grep -v /home
[...]
/usr/share/lightdm/lightdm.conf.d
[...]

Aha, tam jesteś. Co tam jest?

$ ls -1 /usr/share/lightdm/lightdm.conf.d/
50-greeter-wrapper.conf
50-guest-wrapper.conf
50-ubuntu.conf
50-unity-greeter.conf
50-xserver-command.conf

Okay, co tam jest?

$ cat /usr/share/lightdm/lightdm.conf.d/*
[SeatDefaults]
greeter-wrapper=/usr/lib/lightdm/lightdm-greeter-session
[SeatDefaults]
guest-wrapper=/usr/lib/lightdm/lightdm-guest-session
[SeatDefaults]
user-session=ubuntu
[SeatDefaults]
greeter-session=unity-greeter
[SeatDefaults]
# Dump core
xserver-command=X -core

Wniosek

Znajdujemy kilka plików konfiguracyjnych podobnych do formatu INI zgodnie ze schematem nazywania 50-${some-descriptive-name}.conf i konfigurowaniem kluczy dla sekcji [SeatDefaults] .

Nie będziemy edytować żadnego z tych plików , ponieważ są one zarządzane przez menedżera pakietów, ale teraz powinniśmy dodać i zarządzać naszym niestandardowe bity konfiguracyjne do /etc .

Rozwiązanie

Biorąc pod uwagę powyższe, lightdm jest menedżerem wyświetlania, a pliki konfiguracyjne wyglądają jak wyżej. Powinno działać następujące rozwiązanie:

  1. Utwórz brakujące katalogi:

    $ sudo mkdir -p /etc/lightdm/lightdm.conf.d
    
  2. Dodaj niestandardowy plik konfiguracyjny, uruchamiając:

    $ sudo nano /etc/lightdm/lightdm.conf.d/50-disable-guest-session.conf
    

    i wklej następujące linie:

    [SeatDefaults]
    allow-guest=false
    

    Następnie zapisz ( Ctrl + O ) i zamknij ( Ctrl + X ).

  3. Teraz wyloguj się i przełącz na wirtualny terminal ( Ctrl + Alt + F1 ), a następnie uruchom:

    $ sudo service lightdm restart
    

    Opcja sesji gościa powinna już zniknąć. Jeśli coś nie działa poprawnie, teraz wiesz, gdzie jest przechowywana domyślna konfiguracja i czy jej nie zmieniłeś.

Dalsze czytanie

odpowiedział LiveWireBT 16.03.2014, 03:32
źródło
2

Zainstaluj ubuntu-tweak, przejdź do zakładki Dostosuj, wyłącz przycisk gościa i zrestartuj komputer. To jest to!

Terminal może być łatwiejszy, ale w razie potrzeby włączenia konta gościa trzeba będzie ponownie odwiedzić tę stronę i zobaczyć instrukcje (lub raczej cofnąć). To zaleta interfejsu GUI ... łatwo to zapamiętać.

    
odpowiedział tadatma 27.09.2012, 19:33
źródło
2

Zmień allow-guest=true na 'false' w /etc/lightdm/lightdm.conf

Następnie możesz zrestartować lub ponownie uruchomić usługę w terminalu:

sudo restart lightdm

Zakładając, że używasz lightdm , który jest standardowy w 11.10.

    
odpowiedział filescraps 21.10.2011, 12:42
źródło
0

Jestem w tym samym przypadku, plik /etc/lightdm/lightdm.conf nie istnieje w UBUNTU 13.10.

Próbuję utworzyć plik /etc/lightdm/lightdm.conf z tym wierszem allow-guest=false , a CRASH, system nie uruchamia się prawidłowo, tylko tryb konsoli ...

Próbuję edytować plik /etc/lightdm/lightdm.conf.d/10-ubuntu.conf i działa poprawnie.

Edytuj plik

sudo vim /etc/lightdm/lightdm.conf.d/10-ubuntu.conf

I wprowadź wymagane linie

# to disable guest login
allow-guest=false
# to enable user login manually
greeter-show-manual-login=true

I ostatnia, zrestartuj swój system

sudo reboot

Myślę, że to działa dobrze, jeśli uruchomisz ponownie tylko ligthgdm

sudo service lightdm restart
    
odpowiedział Foncu 23.10.2013, 16:05
źródło
0

Otwórz terminal

gksudo gedit /etc/lightdm/lightdm.conf

Dodaj następujący wiersz

allow-guest=false

Zapisz i zamknij plik.

    
odpowiedział scouser73 21.10.2013, 09:29
źródło

Przeczytaj inne pytania na temat tagów