Przycisk wyłączania wylogowuje tylko Ubuntu 15.04

10

Od kiedy uaktualniłem system do wersji Ubuntu 15.04, jeśli kliknę przycisk zamykania, wylogowuje się tylko i muszę ponownie kliknąć przycisk zamykania (z ekranu logowania na Ubuntu), aby wyłączyć komputer. Jak mogę to naprawić?

    
zadawane Hugo Andrade 10.05.2015, 04:12
źródło

3 odpowiedzi

13

Jeśli masz zainstalowany docky naprawił problem dla obu moich maszyn.

Ubuntu 15.04 Unity + Docky, Deska lub Cairo-Dock

(DOCKY)

cd ~/.config/autostart
nano docky.desktop
add X-GNOME-Autostart-Delay=20

(JEŚLI UŻYWAJ CAIRODOCK)

cd ~/.config/autostart
nano cairo-dock.desktop
add X-GNOME-Autostart-Delay=20

Możesz też usunąć jeden z autostartów.

Przykład docky.desktop

[Desktop Entry]
Type=Application
Exec=docky
Hidden=false
NoDisplay=false
X-GNOME-Autostart-Delay=20
X-GNOME-Autostart-enabled=true
Name[en_US]=Docky
Name=Docky
Comment[en_US]=
Comment=

(JEŚLI UŻYWAJ PLANKU)

cd ~/.config/autostart
nano plank.desktop
add X-GNOME-Autostart-Delay=20

Na przykład: cat ~ / .config / autostart / plank.desktop

[Desktop Entry]
Type=Application
Exec=/usr/bin/plank
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
X-GNOME-Autostart-Delay=20
Name=Plank

Uwaga: Nadal dzieje się na Ubuntu 15.10

    
odpowiedział Mad Man 01.08.2015, 20:29
źródło
0

Oto mniej zalecana metoda rozwiązania tego problemu.
1. Najpierw musisz zainstalować narzędzie korekty jedności.
2. Następnie otwórz i przejdź do zakładki "Bezpieczeństwo" w sekcji "System"

3. Możesz zobaczyć, że opcja "Wylogowanie użytkownika" jest zaznaczona, Odznacz ją.

4. Uruchom ponownie swój komputer.

    
odpowiedział Anubhav Jaiswal 20.12.2016, 15:49
źródło
0

Jest to częsty problem spowodowany dodawaniem deski, doku lub innych podobnych doków do pakietów startowych. Ten problem można łatwo rozwiązać, opóźniając się o kilka sekund między zalogowaniem a uruchomieniem aplikacji.

Opóźnienie to można łatwo dodać przez terminal. Na przykład dla docky możesz użyć poleceń:

cd ~/.config/autostart
nano docky.desktop

dodaj

X-GNOME-Autostart-Delay=20

lub możesz po prostu usunąć taki program z autostartu.

    
odpowiedział Siddharth Sharma 28.03.2017, 14:26
źródło

Przeczytaj inne pytania na temat tagów